blob: a2b9c3f7898e28fba55cb52d904f4bcc4e5bdaf4 [file] [log] [blame]
Matt Spinlera48f7f62018-06-21 13:13:52 -05001SUMMARY = "Copy error yaml files to known path for elog parsing"
2PR = "r1"
Patrick Venture9ea4aaf2018-10-24 12:55:20 -07003PV = "1.0+git${SRCPV}"
Matt Spinlera48f7f62018-06-21 13:13:52 -05004LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://${PHOSPHORBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
6
7inherit native
8inherit phosphor-dbus-yaml
9
10require phosphor-led-manager.inc
11
12S = "${WORKDIR}/git"
13
14do_install_append() {
15 SRC=${S}/xyz/openbmc_project/Led/
16 DEST=${D}${yaml_dir}/xyz/openbmc_project/Led/
17 install -d ${DEST}/Fru
18 install ${SRC}/*.errors.yaml ${DEST}
19 install ${SRC}/*.metadata.yaml ${DEST}
20 install ${SRC}/Fru/*.errors.yaml ${DEST}/Fru
21 install ${SRC}/Fru/*.metadata.yaml ${DEST}/Fru
22}