blob: 53263ca032c58fabea757adb5c3367592752a4cf [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "Python tool to parse, validate and convert spdx files"
2HOMEPAGE = "https://github.com/spdx/tools-python"
3
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=dc7f21ccff0f672f2a7cd6f412ae627d"
6
7SRC_URI[sha256sum] = "aea4ac9c2c375e7f439b1cef5ff32ef34914c083de0f61e08ed67cd3d9deb2a9"
8
9BBCLASSEXTEND = "native nativesdk"
10
11inherit setuptools3 pypi
12
13# Dependency required for pyspdxtools : python3-click
14# Dependencies required for conversion to spdx3 : python3-semantic-version, python3-ply
15RDEPENDS:${PN} += "\
16 python3-core \
17 python3-beartype \
18 python3-click \
19 python3-datetime \
20 python3-json \
21 python3-license-expression \
22 python3-ply \
23 python3-pyyaml \
24 python3-rdflib \
25 python3-semantic-version \
26 python3-uritools \
27 python3-xmltodict \
28 "