blob: ce299d6b6358a037973cceabe2f343a0daec24f8 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Additional utilities for the opkg package manager"
2SUMMARY_update-alternatives-opkg = "Utility for managing the alternatives system"
3SECTION = "base"
4HOMEPAGE = "http://git.yoctoproject.org/cgit/cgit.cgi/opkg-utils"
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
7 file://opkg.py;beginline=2;endline=18;md5=ffa11ff3c15eb31c6a7ceaa00cc9f986"
8PROVIDES += "${@bb.utils.contains('PACKAGECONFIG', 'update-alternatives', 'virtual/update-alternatives', '', d)}"
9
Andrew Geissler6ce62a22020-11-30 19:58:47 -060010SRC_URI = "http://git.yoctoproject.org/cgit/cgit.cgi/${BPN}/snapshot/${BPN}-${PV}.tar.gz \
11 file://0001-update-alternatives-correctly-match-priority.patch \
12 "
Andrew Geissler82c905d2020-04-13 13:39:40 -050013UPSTREAM_CHECK_URI = "http://git.yoctoproject.org/cgit/cgit.cgi/opkg-utils/refs/"
14
Andrew Geissler475cb722020-07-10 16:00:51 -050015SRC_URI[md5sum] = "7bbadb3c381f3ea935b21d3bb8cc4671"
16SRC_URI[sha256sum] = "046517600fb0aed6c4645edefe02281f4fa2f1c02f71596152d93172452c0b01"
Andrew Geissler82c905d2020-04-13 13:39:40 -050017
18TARGET_CC_ARCH += "${LDFLAGS}"
19
20RDEPENDS_${PN} += "bash"
21
22inherit perlnative
23
24# For native builds we use the host Python
25PYTHONRDEPS = "python3 python3-shell python3-io python3-math python3-crypt python3-logging python3-fcntl python3-pickle python3-compression python3-stringold"
26PYTHONRDEPS_class-native = ""
27
28PACKAGECONFIG = "python update-alternatives"
29PACKAGECONFIG[python] = ",,,${PYTHONRDEPS}"
30PACKAGECONFIG[update-alternatives] = ",,,"
31
32do_install() {
33 oe_runmake PREFIX=${prefix} DESTDIR=${D} install
34 if ! ${@bb.utils.contains('PACKAGECONFIG', 'update-alternatives', 'true', 'false', d)}; then
35 rm -f "${D}${bindir}/update-alternatives"
36 fi
37}
38
39do_install_append_class-target() {
40 if ! ${@bb.utils.contains('PACKAGECONFIG', 'python', 'true', 'false', d)}; then
41 grep -lZ "/usr/bin/env.*python" ${D}${bindir}/* | xargs -0 rm
42 fi
43
44 if [ -e "${D}${bindir}/update-alternatives" ]; then
45 sed -i ${D}${bindir}/update-alternatives -e 's,/usr/bin,${bindir},g; s,/usr/lib,${nonarch_libdir},g'
46 fi
47}
48
49# These are empty and will pull python3-dev into images where it wouldn't
50# have been otherwise, so don't generate them.
51PACKAGES_remove = "${PN}-dev ${PN}-staticdev"
52
53PACKAGES =+ "update-alternatives-opkg"
54FILES_update-alternatives-opkg = "${bindir}/update-alternatives"
55RPROVIDES_update-alternatives-opkg = "update-alternatives update-alternatives-cworth"
56RREPLACES_update-alternatives-opkg = "update-alternatives-cworth"
57RCONFLICTS_update-alternatives-opkg = "update-alternatives-cworth"
58
59pkg_postrm_update-alternatives-opkg() {
60 rm -rf $D${nonarch_libdir}/opkg/alternatives
61 rmdir $D${nonarch_libdir}/opkg || true
62}
63
64BBCLASSEXTEND = "native nativesdk"
65
66CLEANBROKEN = "1"