blob: 18cb0cd8ef9cb29b767242028d09f2b4a39362ba [file] [log] [blame]
Andrew Geisslera2681d92020-10-16 10:17:07 -05001SUMMARY = "Open source iec61850 implementation"
2DESCRIPTION = "IEC 61850 is an international standard for \
3communication systems in Substation Automation Systems \
4(SAS) and management of Decentralized Energy Resources \
5(DER). It is seen as one of the communication standards \
6of the emerging Smart Grid. \
7The project libIEC61850 provides a server and client \
8library for the IEC 61850/MMS, IEC 61850/GOOSE and IEC \
961850-9-2/Sampled Values communication protocols \
10written in C. It is available under the GPLv3 license."
11HOMEPAGE = "http://libiec61850.com"
12SECTION = "console/network"
13LICENSE = "GPLv3"
14LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
15DEPENDS = "swig-native python3"
16SRCREV = "d798814fb463115a835da597535a625b68a39cff"
17
18SRC_URI = "git://github.com/mz-automation/${BPN}.git;branch=v1.4 \
19 file://0001-use-poll.h-instead-of-sys-poll.h.patch \
20 file://0002-serial_port_linux-Add-missing-include-sys-time.h.patch \
21 file://0003-pyiec61850-don-t-break-CMAKE_INSTALL_PATH-by-trying-.patch \
22"
23
24S = "${WORKDIR}/git"
25
26inherit cmake pkgconfig python3-dir python3native siteinfo
27
28EXTRA_OECMAKE = " \
29 -DBUILD_EXAMPLES=OFF \
30 -DBUILD_PYTHON_BINDINGS=ON \
31"
32
33RDEPENDS_${PN}-python = " python3-core "
34RDEPENDS_${PN} = " python3-core "
35
36FILES_${PN} += " \
37 ${libdir}/${PYTHON_DIR}/site-packages/iec61850.py \
38 ${libdir}/${PYTHON_DIR}/site-packages/_iec61850.so \
39"