blob: 61cf1cc6267253f0c5a6dc69da49b169e070b98a [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "wolfSSL Lightweight Embedded SSL/TLS Library"
2DESCRIPTION = "wolfSSL, formerly CyaSSL, is a lightweight SSL library written \
3 in C and optimized for embedded and RTOS environments. It can \
4 be up to 20 times smaller than OpenSSL while still supporting \
5 a full TLS client and server, up to TLS 1.3"
6HOMEPAGE = "https://www.wolfssl.com/products/wolfssl"
7BUGTRACKER = "https://github.com/wolfssl/wolfssl/issues"
8SECTION = "libs"
9LICENSE = "GPLv2"
10LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
11
12PROVIDES += "cyassl"
13RPROVIDES_${PN} = "cyassl"
14
Andrew Geisslera2681d92020-10-16 10:17:07 -050015SRC_URI = "git://github.com/wolfSSL/wolfssl.git;protocol=https \
16 file://0001-Make-ByteReverseWords-available-for-big-and-little-e.patch \
17"
18SRCREV = "0fa5af9929ce2ee99e8789996a3048f41a99830e"
Andrew Geissler82c905d2020-04-13 13:39:40 -050019S = "${WORKDIR}/git"
20
21inherit autotools
22
23BBCLASSEXTEND += "native nativesdk"