blob: de3fbb094794e3097265d5fc51e449fd2d375bd6 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001DESCRIPTION = "A a package of utilities for doing and managing mounts of the Linux CIFS filesystem."
2HOMEPAGE = "http://wiki.samba.org/index.php/LinuxCIFS_utils"
3SECTION = "otherosfs"
4LICENSE = "GPLv3 & LGPLv3"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
6
Andrew Geisslerd688a012020-09-18 13:36:00 -05007SRCREV = "ded4e81796a18cde73329e838357f084aa05720f"
Andrew Geissler82c905d2020-04-13 13:39:40 -05008SRC_URI = "git://git.samba.org/cifs-utils.git"
9
10S = "${WORKDIR}/git"
11DEPENDS += "libtalloc"
12
13PACKAGECONFIG ??= ""
14PACKAGECONFIG[cap] = "--with-libcap,--without-libcap,libcap"
15# when enabled, it creates ${bindir}/cifscreds and --ignore-fail-on-non-empty in do_install_append is needed
16PACKAGECONFIG[cifscreds] = "--enable-cifscreds,--disable-cifscreds,keyutils"
17# when enabled, it creates ${sbindir}/cifs.upcall and --ignore-fail-on-non-empty in do_install_append is needed
18PACKAGECONFIG[cifsupcall] = "--enable-cifsupcall,--disable-cifsupcall,krb5 libtalloc keyutils"
19PACKAGECONFIG[cifsidmap] = "--enable-cifsidmap,--disable-cifsidmap,keyutils samba"
20PACKAGECONFIG[cifsacl] = "--enable-cifsacl,--disable-cifsacl,samba"
21PACKAGECONFIG[pam] = "--enable-pam --with-pamdir=${base_libdir}/security,--disable-pam,libpam keyutils"
22
23SRC_URI += " \
24 file://0001-Bugfix-Modify-the-dir-of-install-exec-hook-and.patch \
25 "
26
27inherit autotools pkgconfig
28
29do_install_append() {
30 # Remove empty /usr/bin and /usr/sbin directories since the mount helper
31 # is installed to /sbin
32 rmdir --ignore-fail-on-non-empty ${D}${bindir} ${D}${sbindir}
33}
34
35FILES_${PN} += "${base_libdir}/security"
36FILES_${PN}-dbg += "${base_libdir}/security/.debug"
37RRECOMMENDS_${PN} = "kernel-module-cifs"