blob: 374f944096f20152eee534f7dd02d67427bb11cb [file] [log] [blame]
Andrew Geisslera2681d92020-10-16 10:17:07 -05001# Copyright (C) 2020 Armin Kuster <akuster808@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4DESCRIPTION = "Musl-nscd is an implementation of the NSCD protocol, suitable for use with musl and with standard NSS modules"
5HOMEPAGE = "https://github.com/pikhq/musl-nscd"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=9bf479a145bcaff8489e743da58afeee"
8SECTION = "utils"
9
10PV = "1.0.2"
11
12CFLAGS += "-fcommon"
13
14SRCREV = "8f278675e1b6a3a02c8ee1b8ca000f80570dc5d6"
15SRC_URI = "git://github.com/pikhq/musl-nscd"
16
17UPSTREAM_CHECK_COMMITS = "1"
18
19inherit autotools-brokensep
20
21S = "${WORKDIR}/git"
22
23do_configure () {
24 # no debug set -s flag
25 sed -i -e 's/LDFLAGS_AUTO=-s/LDFLAGS_AUTO=/' ${S}/configure
26 ${S}/configure ${CONFIGUREOPTS} ${EXTRA_OECONF}
27}
28
29do_compile () {
30 oe_runmake
31}
32
33do_install () {
34 make DESTDIR=${D} install
35}
36
37COMPATIBLE_HOST = ".*-musl.*"