blob: 5127e11d816f28017820557764b3fcd844d77a15 [file] [log] [blame]
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -05001SUMMARY = "A subproject of Apache NiFi to collect data where it originates."
2DESCRIPTION = "MiNiFi--a subproject of Apache NiFi--is a complementary \
3data collection approach that supplements the core tenets of NiFi in dataflow \
4management, focusing on the collection of data at the source of its creation."
5HOMEPAGE = "https://nifi.apache.org/minifi/index.html"
6SECTION = "console/network"
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=f9534eb5f4ab800b573a37bffc62f3a7"
9
10DEPENDS = "virtual/crypt expat flex python3 bison-native libxml2"
11RDEPENDS_${PN} = "python3-core"
12
13SRCREV = "aa42957a2e227df41510047cece3cd606dc1cb6a"
14SRC_URI = "git://github.com/apache/nifi-minifi-cpp.git \
Andrew Geisslera2681d92020-10-16 10:17:07 -050015 https://curl.haxx.se/download/curl-7.64.0.tar.bz2;name=curl;subdir=git/thirdparty \
16 https://ftp.openbsd.org/pub/OpenBSD/LibreSSL/libressl-2.8.3.tar.gz;name=libressl;subdir=git/thirdparty \
17 ${DEBIAN_MIRROR}/main/o/ossp-uuid/ossp-uuid_1.6.2.orig.tar.gz;name=ossp-uuid;subdir=git/thirdparty \
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050018 file://fix-minifi-compile.patch \
19 file://fix-libressl-compile.patch \
20 file://fix-libressl-avoid-BSWAP-assembly-for-ARM-v6.patch \
21 file://fix-osspuuid-compile.patch \
22 file://fix-osspuuid-cross-compile.patch \
23 file://fix-osspuuid-musl-compile.patch \
24 file://fix-rocksdb-cross-compile.patch \
25 file://remove_const_due_to_std_lock_guard.patch \
26 file://0001-Add-lxml2-to-linker-cmdline-of-xml-is-found.patch \
Andrew Geisslera2681d92020-10-16 10:17:07 -050027 file://0001-CMakeLists.txt-use-curl-local-source-tarball.patch \
28 file://0002-cmake-LibreSSL.cmake-use-libressl-local-source-tarba.patch \
29 file://0003-cmake-BundledOSSPUUID.cmake-use-ossp-uuid-local-sour.patch \
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050030 file://minifi.service \
31 file://systemd-volatile.conf \
32 file://sysvinit-volatile.conf \
33 "
Andrew Geisslera2681d92020-10-16 10:17:07 -050034
35SRC_URI[curl.md5sum] = "d0bcc586873cfef08b4b9594e5395a33"
36SRC_URI[curl.sha256sum] = "d573ba1c2d1cf9d8533fadcce480d778417964e8d04ccddcc76e591d544cf2eb"
37SRC_URI[libressl.md5sum] = "0f1127bd21b4aa8495a910379c2ad936"
38SRC_URI[libressl.sha256sum] = "9b640b13047182761a99ce3e4f000be9687566e0828b4a72709e9e6a3ef98477"
39SRC_URI[ossp-uuid.md5sum] = "5db0d43a9022a6ebbbc25337ae28942f"
40SRC_URI[ossp-uuid.sha256sum] = "11a615225baa5f8bb686824423f50e4427acd3f70d394765bdff32801f0fd5b0"
41
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050042S = "${WORKDIR}/git"
43
44inherit pkgconfig cmake systemd
45
46SYSTEMD_PACKAGES = "minifi-cpp"
47SYSTEMD_SERVICE_${PN} = "minifi.service"
48SYSTEMD_AUTO_ENABLE = "disable"
49
50OECMAKE_FIND_ROOT_PATH_MODE_PROGRAM = "BOTH"
51
52EXTRA_OECMAKE += " \
53 -DHOST_SYS=${HOST_SYS} -DBUILD_SYS=${BUILD_SYS} \
54 -DSKIP_TESTS=ON \
55 "
56EXTRA_OECMAKE_append_toolchain-clang = " -DCMAKE_RANLIB=${STAGING_BINDIR_TOOLCHAIN}/${TARGET_PREFIX}llvm-ranlib"
57LDFLAGS_append_toolchain-clang = " -fuse-ld=lld"
58
59# There are endian issues when communicating with the x86 nifi on the the mips and the ppc machines.
60COMPATIBLE_MACHINE_mips = "(!.*mips).*"
61COMPATIBLE_MACHINE_mips64 = "(!.*mips64).*"
62COMPATIBLE_MACHINE_powerpc = "(!.*ppc).*"
63
64TARGET_CFLAGS_append_riscv32 += "-fpic"
65TARGET_CXXFLAGS_append_riscv32 += "-fpic"
66TARGET_CFLAGS_append_riscv64 += "-fpic"
67TARGET_CXXFLAGS_append_riscv64 += "-fpic"
68
Andrew Geisslera2681d92020-10-16 10:17:07 -050069do_install[cleandirs] += "${WORKDIR}/minifi-install"
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050070
71do_install() {
Andrew Geisslera2681d92020-10-16 10:17:07 -050072 DESTDIR='${WORKDIR}/minifi-install' cmake_runcmake_build --target ${OECMAKE_TARGET_INSTALL}
73 MINIFI_BIN=${bindir}
74 MINIFI_HOME=${sysconfdir}/minifi
75 MINIFI_RUN=${localstatedir}/lib/minifi
76 MINIFI_LOG=${localstatedir}/log/minifi
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050077
78 install -d ${D}${MINIFI_BIN}
79 install -d ${D}${MINIFI_HOME}/conf
Andrew Geisslera2681d92020-10-16 10:17:07 -050080 install -m 755 -d ${D}${localstatedir}/lib/minifi
81 cp -a ${WORKDIR}/minifi-install/usr/bin/* ${D}${MINIFI_BIN}/
82 cp -a ${WORKDIR}/minifi-install/usr/conf/* ${D}${MINIFI_HOME}/conf/
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050083
84 sed -i 's|#appender.rolling.directory=.*|appender.rolling.directory='${MINIFI_LOG}'|g' \
85 ${D}${MINIFI_HOME}/conf/minifi-log.properties
86 sed -i 's|nifi.provenance.repository.directory.default=.*|nifi.provenance.repository.directory.default='${MINIFI_RUN}'/provenance_repository|g' \
87 ${D}${MINIFI_HOME}/conf/minifi.properties
88 sed -i 's|nifi.flowfile.repository.directory.default=.*|nifi.flowfile.repository.directory.default='${MINIFI_RUN}'/flowfile_repository|g' \
89 ${D}${MINIFI_HOME}/conf/minifi.properties
90 sed -i 's|nifi.database.content.repository.directory.default=.*|nifi.database.content.repository.directory.default='${MINIFI_RUN}'/content_repository|g' \
91 ${D}${MINIFI_HOME}/conf/minifi.properties
92 sed -i 's|nifi.flow.configuration.file=.*|nifi.flow.configuration.file='${MINIFI_HOME}'/conf/config.yml|g' \
93 ${D}${MINIFI_HOME}/conf/minifi.properties
94
95 sed -i 's|export MINIFI_HOME=.*|export MINIFI_HOME='${MINIFI_HOME}'|g' ${D}${MINIFI_BIN}/minifi.sh
96 sed -i 's|bin_dir=${MINIFI_HOME}/bin|bin_dir='${MINIFI_BIN}'|g' ${D}${MINIFI_BIN}/minifi.sh
Andrew Geisslera2681d92020-10-16 10:17:07 -050097 sed -i 's|pid_file=${bin_dir}/.|pid_file='${localstatedir}/run/'|g' ${D}${MINIFI_BIN}/minifi.sh
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050098
99 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
100 install -d ${D}${sysconfdir}/tmpfiles.d/
Andrew Geisslera2681d92020-10-16 10:17:07 -0500101 install -m 0644 ${WORKDIR}/systemd-volatile.conf ${D}${sysconfdir}/tmpfiles.d/minifi.conf
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -0500102 install -m 0755 -d ${D}${systemd_unitdir}/system
103 install -m 0644 ${WORKDIR}/minifi.service ${D}${systemd_unitdir}/system/
104
105 sed -i 's|@LOCALSTATEDIR@|${localstatedir}|g' ${D}${systemd_unitdir}/system/minifi.service
106 sed -i 's|@SYSCONFDIR@|${sysconfdir}|g' ${D}${systemd_unitdir}/system/minifi.service
107 sed -i 's|@BINDIR@|${bindir}|g' ${D}${systemd_unitdir}/system/minifi.service
108
Andrew Geisslera2681d92020-10-16 10:17:07 -0500109 sed -i 's|@MINIFI_LOG@|'${MINIFI_LOG}'|g' ${D}${sysconfdir}/tmpfiles.d/minifi.conf
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -0500110
111 elif ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then
112 install -d ${D}${sysconfdir}/default/volatiles
113 install -m 0644 ${WORKDIR}/sysvinit-volatile.conf ${D}${sysconfdir}/default/volatiles/99_minifi
114
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -0500115 sed -i 's|@MINIFI_LOG@|'${MINIFI_LOG}'|g' ${D}${sysconfdir}/default/volatiles/99_minifi
116 fi
117}
118
119pkg_postinst_${PN}() {
120 if [ -z "$D" ]; then
121 if type systemd-tmpfiles >/dev/null; then
122 systemd-tmpfiles --create
123 elif [ -e ${sysconfdir}/init.d/populate-volatile.sh ]; then
124 ${sysconfdir}/init.d/populate-volatile.sh update
125 fi
126 fi
127}