blob: 6433675ca4335dbf89fc1a50d37e3ba258f6ffc1 [file] [log] [blame]
Andrew Geisslera2681d92020-10-16 10:17:07 -05001SUMMARY = "C library and tools for interacting with the linux GPIO character device"
2AUTHOR = "Bartosz Golaszewski <bgolaszewski@baylibre.com>"
Andrew Geissler82c905d2020-04-13 13:39:40 -05003
Andrew Geisslera2681d92020-10-16 10:17:07 -05004LICENSE = "LGPLv2.1+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=2caced0b25dfefd4c601d92bd15116de"
Andrew Geissler82c905d2020-04-13 13:39:40 -05006
Andrew Geisslera2681d92020-10-16 10:17:07 -05007SRC_URI = "https://www.kernel.org/pub/software/libs/${BPN}/${BP}.tar.xz"
Andrew Geisslerd688a012020-09-18 13:36:00 -05008SRC_URI[md5sum] = "064c2627397e6641c52de09a26951112"
9SRC_URI[sha256sum] = "f1cda2789e6a13a92aefc012a76e5a7cc57a1b402d66f71df8719ee314b67699"
Andrew Geissler82c905d2020-04-13 13:39:40 -050010
Andrew Geisslera2681d92020-10-16 10:17:07 -050011inherit autotools pkgconfig python3native
Andrew Geissler82c905d2020-04-13 13:39:40 -050012
Andrew Geissler82c905d2020-04-13 13:39:40 -050013PACKAGECONFIG[tests] = "--enable-tests,--disable-tests,kmod udev"
Andrew Geisslera2681d92020-10-16 10:17:07 -050014PACKAGECONFIG[cxx] = "--enable-bindings-cxx,--disable-bindings-cxx"
Andrew Geissler82c905d2020-04-13 13:39:40 -050015PACKAGECONFIG[python3] = "--enable-bindings-python,--disable-bindings-python,python3"
16
Andrew Geisslera2681d92020-10-16 10:17:07 -050017# Enable cxx bindings by default.
18PACKAGECONFIG ?= "cxx"
19
20# Always build tools - they don't have any additional
21# requirements over the library.
22EXTRA_OECONF = "--enable-tools"
23
24DEPENDS += "autoconf-archive-native"
25
26PACKAGES =+ "${PN}-tools libgpiodcxx"
27FILES_${PN}-tools = "${bindir}/*"
28FILES_libgpiodcxx = "${libdir}/libgpiodcxx.so.*"
Andrew Geissler82c905d2020-04-13 13:39:40 -050029
30PACKAGES =+ "${PN}-python"
31FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR}"
32RRECOMMENDS_PYTHON = "${@bb.utils.contains('PACKAGECONFIG', 'python3', '${PN}-python', '',d)}"
33RRECOMMENDS_${PN}-python += "${RRECOMMENDS_PYTHON}"