Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Hash table and linked list for C structures" |
| 2 | DESCRIPTION = " uthash-dev provides a hash table implementation using C preprocessor macros.\n\ |
| 3 | This package also includes:\n\ |
| 4 | * utlist.h provides linked list macros for C structures\n\ |
| 5 | * utarray.h implements dynamic arrays using macros\n\ |
| 6 | * utstring.h implements a basic dynamic string\n\ |
| 7 | " |
| 8 | HOMEPAGE = "https://troydhanson.github.io/uthash/" |
| 9 | SECTION = "base" |
| 10 | LICENSE = "BSD-1-Clause" |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame] | 11 | LIC_FILES_CHKSUM = "file://LICENSE;md5=736712b5904dd42f8678df7172bc5f2b" |
| 12 | SRCREV = "e493aa90a2833b4655927598f169c31cfcdf7861" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 13 | |
| 14 | SRC_URI = "\ |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 15 | git://github.com/troydhanson/${BPN}.git;branch=master;protocol=https \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 16 | file://run-ptest \ |
| 17 | " |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 18 | |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 19 | S = "${WORKDIR}/git" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 20 | |
| 21 | inherit ptest |
| 22 | |
| 23 | do_compile[noexec] = "1" |
| 24 | |
| 25 | do_compile_ptest() { |
| 26 | oe_runmake -C tests tests_only TEST_TARGET= |
| 27 | } |
| 28 | |
| 29 | do_install () { |
| 30 | install -dm755 ${D}${includedir} |
| 31 | install -m0644 src/*.h ${D}${includedir} |
| 32 | } |
| 33 | |
| 34 | do_install_ptest() { |
| 35 | install -dm755 ${D}${PTEST_PATH}/tests |
| 36 | install -m0755 tests/test*[0-9] ${D}${PTEST_PATH}/tests |
| 37 | install -m0644 tests/test*[0-9].ans ${D}${PTEST_PATH}/tests |
| 38 | install -m0644 tests/test*[0-9].dat ${D}${PTEST_PATH}/tests |
| 39 | } |
| 40 | |
| 41 | # The main package is empty and non-existent, so -dev |
| 42 | # should not depend on it... |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 43 | RDEPENDS:${PN}-dev = "" |
| 44 | RDEPENDS:${PN}-ptest:remove = "${PN}" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 45 | |
| 46 | BBCLASSEXTEND = "native" |