blob: d0c47c055ea0820ff493b25178083b4e350d9572 [file] [log] [blame]
Grant Williamsa2b58592022-06-07 16:14:36 -05001SUMMARY = "Phosphor OpenBMC Mori BIOS Firmware Upgrade Command"
2DESCRIPTION = "Phosphor OpenBMC Mori BIOS Firmware Upgrade Comman Daemon"
3
4PR = "r1"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
7
8inherit systemd
9inherit obmc-phosphor-systemd
10
11DEPENDS += "systemd"
12DEPENDS += "phosphor-ipmi-flash"
13RDEPENDS:${PN} += "libsystemd"
14RDEPENDS:${PN} += "mori-fw"
15PROVIDES += "virtual/bios-update"
16RPROVIDES:${PN} += "virtual/bios-update"
17
18FILES:${PN} += "${datadir}/phosphor-ipmi-flash/config-bios.json"
19
20SRC_URI += " \
21 file://phosphor-ipmi-flash-bios-update.service \
22 file://config-bios.json \
23 "
24
25SYSTEMD_PACKAGES = "${PN}"
26SYSTEMD_SERVICE:${PN} += " \
27 phosphor-ipmi-flash-bios-update.service \
28 "
29
30do_install () {
31 install -d ${D}${datadir}/phosphor-ipmi-flash
32 install -m 0644 ${WORKDIR}/config-bios.json ${D}${datadir}/phosphor-ipmi-flash
33 install -d ${D}${systemd_system_unitdir}
34 install -m 0644 ${WORKDIR}/phosphor-ipmi-flash-bios-update.service ${D}${systemd_system_unitdir}
35}