blob: 7b19f8e14f48ea162cd958614b395094d51c9bc9 [file] [log] [blame]
Grant Williamsa2b58592022-06-07 16:14:36 -05001SUMMARY = "Phosphor OpenBMC Mori CPLD Firmware Upgrade Command"
2DESCRIPTION = "Phosphor OpenBMC Mori CPLD Firmware Upgrade Comman Daemon"
3
4PR = "r1"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
7
8inherit systemd
9inherit obmc-phosphor-systemd
10
11DEPENDS += "systemd"
12DEPENDS += "phosphor-ipmi-flash"
13RDEPENDS:${PN} += "libsystemd"
14RDEPENDS:${PN} += "mori-fw"
15PROVIDES += "virtual/cpld-update"
16RPROVIDES:${PN} += "virtual/cpld-update"
17
18FILES:${PN} += "${datadir}/phosphor-ipmi-flash/config-bmccpld.json"
19FILES:${PN} += "${datadir}/phosphor-ipmi-flash/config-mbcpld.json"
20
21SRC_URI += " \
22 file://phosphor-ipmi-flash-bmccpld-update.service \
23 file://phosphor-ipmi-flash-mbcpld-update.service \
24 file://config-bmccpld.json \
25 file://config-mbcpld.json \
26 "
27
28SYSTEMD_PACKAGES = "${PN}"
29SYSTEMD_SERVICE:${PN} += " \
30 phosphor-ipmi-flash-bmccpld-update.service \
31 phosphor-ipmi-flash-mbcpld-update.service \
32 "
33
34do_install () {
35 install -d ${D}${datadir}/phosphor-ipmi-flash
36 install -m 0644 ${WORKDIR}/config-bmccpld.json ${D}${datadir}/phosphor-ipmi-flash
37 install -m 0644 ${WORKDIR}/config-mbcpld.json ${D}${datadir}/phosphor-ipmi-flash
38 install -d ${D}${systemd_system_unitdir}
39 install -m 0644 ${WORKDIR}/phosphor-ipmi-flash-bmccpld-update.service ${D}${systemd_system_unitdir}
40 install -m 0644 ${WORKDIR}/phosphor-ipmi-flash-mbcpld-update.service ${D}${systemd_system_unitdir}
41}