blob: 135d8e7f75b2f24793716a0f83894e7685a08e25 [file] [log] [blame]
Delphine CC Chiu9d5d2482023-10-18 18:39:21 +08001FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
2
3inherit obmc-phosphor-systemd systemd
4
5SRC_URI += "file://yosemite4-phosphor-multi-gpio-monitor.json \
6 file://set-button-sled.service \
Delphine CC Chiu6e311d32023-11-15 15:40:58 +08007 file://probe-slot-device@.service \
8 file://probe-slot-device \
Delphine CC Chiu085d6192023-11-24 16:02:08 +08009 file://rescan-fru-device@.service \
10 file://rescan-fru-device \
Delphine CC Chiu2f1f94c2024-01-12 17:22:20 +080011 file://slot-hot-plug@.service \
Delphine CC Chiu9d5d2482023-10-18 18:39:21 +080012 "
13
Patrick Williamsa2fb20c2024-02-05 14:11:29 -060014RDEPENDS:${PN}:append = " bash"
Delphine CC Chiu6e311d32023-11-15 15:40:58 +080015
Delphine CC Chiu9d5d2482023-10-18 18:39:21 +080016FILES:${PN} += "${systemd_system_unitdir}/*"
17
18SYSTEMD_SERVICE:${PN} += " \
19 set-button-sled.service \
Delphine CC Chiu6e311d32023-11-15 15:40:58 +080020 probe-slot-device@.service \
Delphine CC Chiu085d6192023-11-24 16:02:08 +080021 rescan-fru-device@.service \
Delphine CC Chiu2f1f94c2024-01-12 17:22:20 +080022 slot-hot-plug@.service \
Delphine CC Chiu9d5d2482023-10-18 18:39:21 +080023 "
Delphine CC Chiu6e311d32023-11-15 15:40:58 +080024
Delphine CC Chiu9d5d2482023-10-18 18:39:21 +080025SYSTEMD_AUTO_ENABLE = "enable"
26
27do_install:append:() {
28 install -d ${D}${datadir}/phosphor-gpio-monitor
29 install -m 0644 ${WORKDIR}/yosemite4-phosphor-multi-gpio-monitor.json \
30 ${D}${datadir}/phosphor-gpio-monitor/phosphor-multi-gpio-monitor.json
31 install -m 0644 ${WORKDIR}/set-button-sled.service ${D}${systemd_system_unitdir}/set-button-sled.service
Delphine CC Chiu6e311d32023-11-15 15:40:58 +080032 install -m 0644 ${WORKDIR}/probe-slot-device@.service ${D}${systemd_system_unitdir}/probe-slot-device@.service
Delphine CC Chiu085d6192023-11-24 16:02:08 +080033 install -m 0644 ${WORKDIR}/rescan-fru-device@.service ${D}${systemd_system_unitdir}/rescan-fru-device@.service
Delphine CC Chiu2f1f94c2024-01-12 17:22:20 +080034 install -m 0644 ${WORKDIR}/slot-hot-plug@.service ${D}${systemd_system_unitdir}/slot-hot-plug@.service
Delphine CC Chiu6e311d32023-11-15 15:40:58 +080035 install -d ${D}${libexecdir}/${PN}
Patrick Williamsd3135242024-01-19 16:45:58 -060036 install -m 0755 ${WORKDIR}/probe-slot-device ${D}${libexecdir}/${PN}/
37 install -m 0755 ${WORKDIR}/rescan-fru-device ${D}${libexecdir}/${PN}/
Delphine CC Chiu9d5d2482023-10-18 18:39:21 +080038}