blob: aaa198ea23ec4039c0b48e9a68d0fcb710da7bfe [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001require grub2.inc
2
3GRUBPLATFORM = "efi"
4
5DEPENDS_append_class-target = " grub-efi-native"
Brad Bishop316dfdd2018-06-25 12:45:53 -04006RDEPENDS_${PN}_class-target = "diffutils freetype grub-common virtual/grub-bootconf"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05007
8SRC_URI += " \
9 file://cfg \
10 "
11
12S = "${WORKDIR}/grub-${PV}"
13
14# Determine the target arch for the grub modules
15python __anonymous () {
16 import re
17 target = d.getVar('TARGET_ARCH')
Brad Bishop316dfdd2018-06-25 12:45:53 -040018 prefix = "" if d.getVar('EFI_PROVIDER') == "grub-efi" else "grub-efi-"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050019 if target == "x86_64":
20 grubtarget = 'x86_64'
Brad Bishop316dfdd2018-06-25 12:45:53 -040021 grubimage = prefix + "bootx64.efi"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050022 elif re.match('i.86', target):
23 grubtarget = 'i386'
Brad Bishop316dfdd2018-06-25 12:45:53 -040024 grubimage = prefix + "bootia32.efi"
25 elif re.match('aarch64', target):
26 grubtarget = 'arm64'
27 grubimage = prefix + "bootaa64.efi"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080028 elif re.match('arm', target):
29 grubtarget = 'arm'
30 grubimage = prefix + "bootarm.efi"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050031 else:
Brad Bishop316dfdd2018-06-25 12:45:53 -040032 raise bb.parse.SkipRecipe("grub-efi is incompatible with target %s" % target)
Brad Bishopd7bf8c12018-02-25 22:55:05 -050033 d.setVar("GRUB_TARGET", grubtarget)
34 d.setVar("GRUB_IMAGE", grubimage)
Brad Bishop316dfdd2018-06-25 12:45:53 -040035 prefix = "grub-efi-" if prefix == "" else ""
36 d.setVar("GRUB_IMAGE_PREFIX", prefix)
Brad Bishopd7bf8c12018-02-25 22:55:05 -050037}
38
39inherit deploy
40
41CACHED_CONFIGUREVARS += "ac_cv_path_HELP2MAN="
42EXTRA_OECONF += "--enable-efiemu=no"
43
Brad Bishop316dfdd2018-06-25 12:45:53 -040044do_mkimage() {
45 cd ${B}
46 # Search for the grub.cfg on the local boot media by using the
47 # built in cfg file provided via this recipe
48 grub-mkimage -c ../cfg -p /EFI/BOOT -d ./grub-core/ \
49 -O ${GRUB_TARGET}-efi -o ./${GRUB_IMAGE_PREFIX}${GRUB_IMAGE} \
50 ${GRUB_BUILDIN}
51}
52
53addtask mkimage before do_install after do_compile
54
55do_mkimage_class-native() {
56 :
57}
58
59do_install_append_class-target() {
60 install -d ${D}/boot
61 install -d ${D}/boot/EFI
62 install -d ${D}/boot/EFI/BOOT
63 install -m 644 ${B}/${GRUB_IMAGE_PREFIX}${GRUB_IMAGE} ${D}/boot/EFI/BOOT/${GRUB_IMAGE}
64}
65
Brad Bishopd7bf8c12018-02-25 22:55:05 -050066do_install_class-native() {
67 install -d ${D}${bindir}
68 install -m 755 grub-mkimage ${D}${bindir}
Brad Bishopc342db32019-05-15 21:57:59 -040069 install -m 755 grub-editenv ${D}${bindir}
Brad Bishopd7bf8c12018-02-25 22:55:05 -050070}
71
Brad Bishop316dfdd2018-06-25 12:45:53 -040072do_install_class-target() {
73 oe_runmake 'DESTDIR=${D}' -C grub-core install
74
Brad Bishopd7bf8c12018-02-25 22:55:05 -050075 # Remove build host references...
76 find "${D}" -name modinfo.sh -type f -exec \
77 sed -i \
78 -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
79 -e 's|${DEBUG_PREFIX_MAP}||g' \
80 -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
81 {} +
82}
83
Brad Bishop08902b02019-08-20 09:16:51 -040084do_install_append_aarch64() {
85 rm -rf ${D}/${prefix}/
86}
87
Brad Bishopd7bf8c12018-02-25 22:55:05 -050088GRUB_BUILDIN ?= "boot linux ext2 fat serial part_msdos part_gpt normal \
Brad Bishop316dfdd2018-06-25 12:45:53 -040089 efi_gop iso9660 configfile search loadenv test"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050090
91do_deploy() {
Brad Bishop316dfdd2018-06-25 12:45:53 -040092 install -m 644 ${B}/${GRUB_IMAGE_PREFIX}${GRUB_IMAGE} ${DEPLOYDIR}
Brad Bishopd7bf8c12018-02-25 22:55:05 -050093}
94
95do_deploy_class-native() {
96 :
97}
98
99addtask deploy after do_install before do_build
100
Brad Bishop316dfdd2018-06-25 12:45:53 -0400101FILES_${PN} = "${libdir}/grub/${GRUB_TARGET}-efi \
102 ${datadir}/grub \
103 /boot/EFI/BOOT/${GRUB_IMAGE} \
104 "
105
Brad Bishop08902b02019-08-20 09:16:51 -0400106FILES_${PN}_remove_aarch64 = "${libdir}/grub/${GRUB_TARGET}-efi"
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500107
108# 64-bit binaries are expected for the bootloader with an x32 userland
109INSANE_SKIP_${PN}_append_linux-gnux32 = " arch"
110INSANE_SKIP_${PN}-dbg_append_linux-gnux32 = " arch"
111INSANE_SKIP_${PN}_append_linux-muslx32 = " arch"
112INSANE_SKIP_${PN}-dbg_append_linux-muslx32 = " arch"