blob: 80189e3ff1f5981308196db3642029c8a3d72fff [file] [log] [blame]
Patrick Williamsc0f7c042017-02-23 20:41:17 -06001require ${BPN}.inc
2
3SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/${PV}/mesa-${PV}.tar.xz \
4 file://replace_glibc_check_with_linux.patch \
5 file://clang-compile-PR89599.patch \
6 file://disable-asm-on-non-gcc.patch \
7"
8
9SRC_URI[md5sum] = "972fd5ad5a63aeabf173fb9adefc6522"
10SRC_URI[sha256sum] = "bab24fb79f78c876073527f515ed871fc9c81d816f66c8a0b051d8d653896389"
11
12#because we cannot rely on the fact that all apps will use pkgconfig,
13#make eglplatform.h independent of MESA_EGL_NO_X11_HEADER
14do_install_append() {
15 if ${@bb.utils.contains('PACKAGECONFIG', 'egl', 'true', 'false', d)}; then
16 sed -i -e 's/^#if defined(MESA_EGL_NO_X11_HEADERS)$/#if defined(MESA_EGL_NO_X11_HEADERS) || ${@bb.utils.contains('PACKAGECONFIG', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
17 fi
18}