blob: 9bca87514bcba4d1e642ac1f33ba88e4aa68d536 [file] [log] [blame]
Brian Mad4211692023-07-05 10:46:47 +08001SUMMARY = "EDID to JSON tool"
2DESCRIPTION = "This is a collection of tools that helps you work with \
3EDID files, by parsing them as well as by converting between EDID \
4binaries and JSON files."
5HOMEPAGE = "https://github.com/rpavlik/edid-json-tools"
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=dc64d2d7c140d9bd69045b5abaede3a7"
8
9SRC_URI = "git://github.com/rpavlik/edid-json-tools.git;branch=main;protocol=https"
10SRCREV = "1cb9416c10c8186b572fbbc98b51b67c00ec2e70"
11
12S = "${WORKDIR}/git"
13
14inherit setuptools3
15PIP_INSTALL_PACKAGE = "edid-json-tools"
16
17RDEPENDS:${PN} += " \
18 python3-click \
19"
20BBCLASSEXTEND = "native"