Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "System load testing utility" |
| 2 | DESCRIPTION = "Deliberately simple workload generator for POSIX systems. It \ |
| 3 | imposes a configurable amount of CPU, memory, I/O, and disk stress on the system." |
| 4 | HOMEPAGE = "https://github.com/ColinIanKing/stress-ng#readme" |
| 5 | LICENSE = "GPL-2.0-only" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 7 | |
| 8 | SRC_URI = "git://github.com/ColinIanKing/stress-ng.git;protocol=https;branch=master \ |
| 9 | " |
Patrick Williams | 56b44a9 | 2024-01-19 08:49:29 -0600 | [diff] [blame] | 10 | SRCREV = "2f22ad595f067aa940cfe4f64107e10872c2f7b5" |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 11 | S = "${WORKDIR}/git" |
| 12 | |
| 13 | DEPENDS = "coreutils-native libbsd" |
| 14 | |
| 15 | PROVIDES = "stress" |
| 16 | RPROVIDES:${PN} = "stress" |
| 17 | RREPLACES:${PN} = "stress" |
| 18 | RCONFLICTS:${PN} = "stress" |
| 19 | |
| 20 | inherit bash-completion |
| 21 | |
| 22 | EXTRA_OEMAKE = "VERBOSE=1" |
| 23 | |
| 24 | do_configure() { |
| 25 | mkdir -p configs |
| 26 | touch configs/HAVE_APPARMOR |
| 27 | oe_runmake makeconfig |
| 28 | } |
| 29 | |
| 30 | do_install() { |
| 31 | oe_runmake DESTDIR=${D} BINDIR=${bindir} install |
| 32 | ln -s stress-ng ${D}${bindir}/stress |
| 33 | } |
| 34 | |
| 35 | # upstream issue: https://github.com/ColinIanKing/stress-ng/issues/315 |
| 36 | DEBUG_BUILD = "0" |