Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Universally Unique Identifier (UUID) library" |
| 2 | DESCRIPTION = "OSSP uuid is a ISO-C:1999 application programming interface \ |
| 3 | (API) and corresponding command line interface (CLI) for the generation of \ |
| 4 | DCE 1.1, ISO/IEC 11578:1996 and RFC 4122 compliant Universally Unique \ |
| 5 | Identifier (UUID). It supports DCE 1.1 variant UUIDs of version 1 (time \ |
| 6 | and node based), version 3 (name based, MD5), version 4 (random number \ |
| 7 | based) and version 5 (name based, SHA-1)." |
| 8 | DESCRIPTION_uuid = "This package contains a tool to create Universally \ |
| 9 | Unique Identifiers (UUID) from the command-line." |
| 10 | |
| 11 | HOMEPAGE = "http://www.ossp.org/pkg/lib/uuid/" |
| 12 | SECTION = "libs" |
| 13 | |
| 14 | LICENSE = "MIT" |
| 15 | LIC_FILES_CHKSUM = "file://README;beginline=30;endline=55;md5=b394fadb039bbfca6ad9d9d769ee960e \ |
| 16 | file://uuid_md5.c;beginline=1;endline=28;md5=9c1f4b2218546deae24c91be1dcf00dd" |
| 17 | |
| 18 | PR = "r2" |
| 19 | |
| 20 | SRC_URI = "${DEBIAN_MIRROR}/main/o/${BPN}/${BPN}_${PV}.orig.tar.gz \ |
| 21 | file://0001-Change-library-name.patch \ |
| 22 | file://0002-uuid-preserve-m-option-status-in-v-option-handling.patch \ |
| 23 | file://0003-Fix-whatis-entries.patch \ |
| 24 | file://0004-fix-data-uuid-from-string.patch \ |
| 25 | file://uuid-libtool.patch \ |
| 26 | file://uuid-nostrip.patch \ |
| 27 | file://install-pc.patch \ |
| 28 | file://ldflags.patch \ |
| 29 | " |
| 30 | SRC_URI[md5sum] = "5db0d43a9022a6ebbbc25337ae28942f" |
| 31 | SRC_URI[sha256sum] = "11a615225baa5f8bb686824423f50e4427acd3f70d394765bdff32801f0fd5b0" |
| 32 | |
| 33 | S = "${WORKDIR}/uuid-${PV}" |
| 34 | |
| 35 | inherit autotools update-alternatives |
| 36 | |
| 37 | EXTRA_OECONF = "--without-dce --without-cxx --without-perl --without-perl-compat --without-php --without-pgsql" |
| 38 | EXTRA_OECONF = "--includedir=${includedir}/ossp" |
| 39 | |
| 40 | do_configure_prepend() { |
| 41 | # This package has a completely custom aclocal.m4, which should be acinclude.m4. |
| 42 | if [ ! -e ${S}/acinclude.m4 ]; then |
| 43 | mv ${S}/aclocal.m4 ${S}/acinclude.m4 |
| 44 | fi |
| 45 | |
| 46 | rm -f ${S}/libtool.m4 |
| 47 | } |
| 48 | |
| 49 | do_install_append() { |
| 50 | mkdir -p ${D}${includedir}/ossp |
| 51 | mv ${D}${libdir}/pkgconfig/uuid.pc ${D}${libdir}/pkgconfig/ossp-uuid.pc |
| 52 | } |
| 53 | |
| 54 | PACKAGES =+ "uuid" |
| 55 | FILES_uuid = "${bindir}/uuid" |
| 56 | FILES_${PN} = "${libdir}/libossp-uuid.so.16*" |
| 57 | FILES_${PN}-dev += "${bindir}/uuid-config" |
| 58 | |
| 59 | BBCLASSEXTEND = "native nativesdk" |
| 60 | |
| 61 | ALTERNATIVE_${PN}-doc = "uuid.3" |
| 62 | ALTERNATIVE_PRIORITY_${PN}-doc = "200" |
| 63 | ALTERNATIVE_LINK_NAME[uuid.3] = "${mandir}/man3/uuid.3" |