blob: 32230a57dfa088aaae9ef712e7531606d5291df2 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "AppArmor another MAC control system"
2DESCRIPTION = "user-space parser utility for AppArmor \
3 This provides the system initialization scripts needed to use the \
4 AppArmor Mandatory Access Control system, including the AppArmor Parser \
5 which is required to convert AppArmor text profiles into machine-readable \
6 policies that are loaded into the kernel for use with the AppArmor Linux \
7 Security Module."
8HOMEAPAGE = "http://apparmor.net/"
9SECTION = "admin"
10
11LICENSE = "GPLv2 & GPLv2+ & BSD-3-Clause & LGPLv2.1+"
12LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=fd57a4b0bc782d7b80fd431f10bbf9d0"
13
14DEPENDS = "bison-native apr gettext-native coreutils-native"
15
16SRC_URI = " \
Brad Bishopc342db32019-05-15 21:57:59 -040017 git://gitlab.com/apparmor/apparmor.git;protocol=https;branch=apparmor-2.13 \
Brad Bishop19323692019-04-05 15:28:33 -040018 file://disable_perl_h_check.patch \
19 file://crosscompile_perl_bindings.patch \
20 file://apparmor.rc \
21 file://functions \
22 file://apparmor \
23 file://apparmor.service \
Brad Bishopf0244752019-09-30 07:50:12 -040024 file://0001-Makefile.am-suppress-perllocal.pod.patch \
Brad Bishop19323692019-04-05 15:28:33 -040025 file://run-ptest \
26 "
27
Brad Bishop49e29a12019-09-01 15:21:06 -040028SRCREV = "2f9d9ea7e01a115b29858455d3b1b5c6a0bab75c"
Brad Bishopc342db32019-05-15 21:57:59 -040029S = "${WORKDIR}/git"
Brad Bishop19323692019-04-05 15:28:33 -040030
31PARALLEL_MAKE = ""
32
Brad Bishopa48c0142020-01-06 09:48:41 -050033inherit pkgconfig autotools-brokensep update-rc.d python3native perlnative ptest cpan manpages systemd features_check
34REQUIRED_DISTRO_FEATURES = "apparmor"
Brad Bishop19323692019-04-05 15:28:33 -040035
Brad Bishop64940c32019-10-15 07:47:39 -040036PACKAGECONFIG ??= "python perl aa-decode"
Brad Bishop19323692019-04-05 15:28:33 -040037PACKAGECONFIG[manpages] = "--enable-man-pages, --disable-man-pages"
38PACKAGECONFIG[python] = "--with-python, --without-python, python3 swig-native"
39PACKAGECONFIG[perl] = "--with-perl, --without-perl, perl perl-native swig-native"
40PACKAGECONFIG[apache2] = ",,apache2,"
Brad Bishop64940c32019-10-15 07:47:39 -040041PACKAGECONFIG[aa-decode] = ",,,bash"
Brad Bishop19323692019-04-05 15:28:33 -040042
43PAMLIB="${@bb.utils.contains('DISTRO_FEATURES', 'pam', '1', '0', d)}"
44HTTPD="${@bb.utils.contains('PACKAGECONFIG', 'apache2', '1', '0', d)}"
45
Brad Bishop19323692019-04-05 15:28:33 -040046python() {
47 if 'apache2' in d.getVar('PACKAGECONFIG').split() and \
48 'webserver' not in d.getVar('BBFILE_COLLECTIONS').split():
49 raise bb.parse.SkipRecipe('Requires meta-webserver to be present.')
50}
51
52DISABLE_STATIC = ""
53
54do_configure() {
55 cd ${S}/libraries/libapparmor
56 aclocal
57 autoconf --force
58 libtoolize --automake -c --force
59 automake -ac
60 ./configure ${CONFIGUREOPTS} ${EXTRA_OECONF}
61}
62
63do_compile () {
64 # Fixes:
65 # | sed -ie 's///g' Makefile.perl
66 # | sed: -e expression #1, char 0: no previous regular expression
67 #| Makefile:478: recipe for target 'Makefile.perl' failed
68 sed -i "s@sed -ie 's///g' Makefile.perl@@" ${S}/libraries/libapparmor/swig/perl/Makefile
69
70
71 oe_runmake -C ${B}/libraries/libapparmor
72 oe_runmake -C ${B}/binutils
73 oe_runmake -C ${B}/utils
74 oe_runmake -C ${B}/parser
75 oe_runmake -C ${B}/profiles
76
77 if test -z "${HTTPD}" ; then
78 oe_runmake -C ${B}/changehat/mod_apparmor
79 fi
80
81 if test -z "${PAMLIB}" ; then
82 oe_runmake -C ${B}/changehat/pam_apparmor
83 fi
84}
85
86do_install () {
87 install -d ${D}/${INIT_D_DIR}
88 install -d ${D}/lib/apparmor
Brad Bishop19323692019-04-05 15:28:33 -040089 oe_runmake -C ${B}/libraries/libapparmor DESTDIR="${D}" install
90 oe_runmake -C ${B}/binutils DESTDIR="${D}" install
91 oe_runmake -C ${B}/utils DESTDIR="${D}" install
92 oe_runmake -C ${B}/parser DESTDIR="${D}" install
93 oe_runmake -C ${B}/profiles DESTDIR="${D}" install
94
95 # If perl is disabled this script won't be any good
96 if ! ${@bb.utils.contains('PACKAGECONFIG','perl','true','false', d)}; then
97 rm -f ${D}${sbindir}/aa-notify
98 fi
99
Brad Bishop64940c32019-10-15 07:47:39 -0400100 if ! ${@bb.utils.contains('PACKAGECONFIG','aa-decode','true','false', d)}; then
101 rm -f ${D}${sbindir}/aa-decode
102 fi
103
Brad Bishop19323692019-04-05 15:28:33 -0400104 if test -z "${HTTPD}" ; then
105 oe_runmake -C ${B}/changehat/mod_apparmor DESTDIR="${D}" install
106 fi
107
108 if test -z "${PAMLIB}" ; then
109 oe_runmake -C ${B}/changehat/pam_apparmor DESTDIR="${D}" install
110 fi
111
112 # aa-easyprof is installed by python-tools-setup.py, fix it up
113 sed -i -e 's:/usr/bin/env.*:/usr/bin/python3:' ${D}${bindir}/aa-easyprof
114 chmod 0755 ${D}${bindir}/aa-easyprof
115
116 install ${WORKDIR}/apparmor ${D}/${INIT_D_DIR}/apparmor
117 install ${WORKDIR}/functions ${D}/lib/apparmor
Brad Bishop5b842c82019-10-21 08:43:46 -0400118 sed -i -e 's/getconf _NPROCESSORS_ONLN/nproc/' ${D}/lib/apparmor/functions
119 sed -i -e 's/ls -AU/ls -A/' ${D}/lib/apparmor/functions
120
121 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
122 install -d ${D}${systemd_system_unitdir}
123 install ${WORKDIR}/apparmor.service ${D}${systemd_system_unitdir}
124 fi
125}
126
127#Building ptest on arm fails.
128do_compile_ptest_aarch64 () {
129 :
130}
131
132do_compile_ptest_arm () {
133 :
Brad Bishop19323692019-04-05 15:28:33 -0400134}
135
136do_compile_ptest () {
137 oe_runmake -C ${B}/tests/regression/apparmor
138 oe_runmake -C ${B}/parser/tst
139 oe_runmake -C ${B}/libraries/libapparmor
140}
141
142do_install_ptest () {
143 t=${D}/${PTEST_PATH}/testsuite
144 install -d ${t}
145 install -d ${t}/tests/regression/apparmor
146 cp -rf ${B}/tests/regression/apparmor ${t}/tests/regression
147
148 install -d ${t}/parser/tst
149 cp -rf ${B}/parser/tst ${t}/parser
150 cp ${B}/parser/apparmor_parser ${t}/parser
151 cp ${B}/parser/frob_slack_rc ${t}/parser
152
153 install -d ${t}/libraries/libapparmor
154 cp -rf ${B}/libraries/libapparmor ${t}/libraries
155
156 install -d ${t}/common
157 cp -rf ${B}/common ${t}
158
159 install -d ${t}/binutils
160 cp -rf ${B}/binutils ${t}
161}
162
Brad Bishop5b842c82019-10-21 08:43:46 -0400163#Building ptest on arm fails.
164do_install_ptest_aarch64 () {
165 :
166}
167
168do_install_ptest_arm() {
169 :
170}
171
Brad Bishop49e29a12019-09-01 15:21:06 -0400172pkg_postinst_ontarget_${PN} () {
173if [ ! -d /etc/apparmor.d/cache ] ; then
174 mkdir /etc/apparmor.d/cache
175fi
176}
177
Brad Bishop5b842c82019-10-21 08:43:46 -0400178# We need the init script so don't rm it
179RMINITDIR_class-target_remove = " rm_sysvinit_initddir"
180
Brad Bishop19323692019-04-05 15:28:33 -0400181INITSCRIPT_PACKAGES = "${PN}"
182INITSCRIPT_NAME = "apparmor"
183INITSCRIPT_PARAMS = "start 16 2 3 4 5 . stop 35 0 1 6 ."
184
185SYSTEMD_PACKAGES = "${PN}"
186SYSTEMD_SERVICE_${PN} = "apparmor.service"
Brad Bishop5b842c82019-10-21 08:43:46 -0400187SYSTEMD_AUTO_ENABLE ?= "enable"
Brad Bishop19323692019-04-05 15:28:33 -0400188
189PACKAGES += "mod-${PN}"
190
191FILES_${PN} += "/lib/apparmor/ ${sysconfdir}/apparmor ${PYTHON_SITEPACKAGES_DIR}"
192FILES_mod-${PN} = "${libdir}/apache2/modules/*"
193
Brad Bishop49e29a12019-09-01 15:21:06 -0400194RDEPENDS_${PN} += "${@bb.utils.contains('PACKAGECONFIG','python','python3-core python3-modules','', d)}"
Brad Bishop19323692019-04-05 15:28:33 -0400195RDEPENDS_${PN}_remove += "${@bb.utils.contains('PACKAGECONFIG','perl','','perl', d)}"
196RDEPENDS_${PN}-ptest += "perl coreutils dbus-lib bash"
Brad Bishop64940c32019-10-15 07:47:39 -0400197
198PRIVATE_LIBS_${PN}-ptest = "libapparmor.so*"