Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "OpenMAX IL plugins for GStreamer" |
| 2 | HOMEPAGE = "http://gstreamer.freedesktop.org/" |
| 3 | SECTION = "multimedia" |
| 4 | |
| 5 | LICENSE = "LGPLv2.1" |
| 6 | LICENSE_FLAGS = "commercial" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c \ |
| 8 | file://omx/gstomx.h;beginline=1;endline=21;md5=5c8e1fca32704488e76d2ba9ddfa935f" |
| 9 | |
| 10 | SRC_URI = "http://gstreamer.freedesktop.org/src/gst-omx/gst-omx-${PV}.tar.xz" |
| 11 | |
Brad Bishop | a5c52ff | 2018-11-23 10:55:50 +1300 | [diff] [blame] | 12 | SRC_URI[md5sum] = "81e67ea03be607b7c548ce911598d754" |
| 13 | SRC_URI[sha256sum] = "969870e75c1f75c96f8783530e2c2932fc3afbfd976eb0c466f51dae268ea3d4" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 14 | |
| 15 | S = "${WORKDIR}/gst-omx-${PV}" |
| 16 | |
| 17 | DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad" |
| 18 | |
| 19 | inherit autotools pkgconfig gettext gtk-doc upstream-version-is-even |
| 20 | |
| 21 | acpaths = "-I ${S}/common/m4 -I ${S}/m4" |
| 22 | |
| 23 | GSTREAMER_1_0_OMX_TARGET ?= "bellagio" |
| 24 | GSTREAMER_1_0_OMX_CORE_NAME ?= "${libdir}/libomxil-bellagio.so.0" |
| 25 | |
| 26 | EXTRA_OECONF += "--disable-valgrind --with-omx-target=${GSTREAMER_1_0_OMX_TARGET}" |
| 27 | |
| 28 | python __anonymous () { |
| 29 | omx_target = d.getVar("GSTREAMER_1_0_OMX_TARGET") |
| 30 | if omx_target in ['generic', 'bellagio']: |
| 31 | # Bellagio headers are incomplete (they are missing the OMX_VERSION_MAJOR,# |
| 32 | # OMX_VERSION_MINOR, OMX_VERSION_REVISION, and OMX_VERSION_STEP macros); |
| 33 | # appending a directory path to gst-omx' internal OpenMAX IL headers fixes this |
| 34 | d.appendVar("CFLAGS", " -I${S}/omx/openmax") |
| 35 | elif omx_target == "rpi": |
| 36 | # Dedicated Raspberry Pi OpenMAX IL support makes this package machine specific |
| 37 | d.setVar("PACKAGE_ARCH", d.getVar("MACHINE_ARCH")) |
| 38 | } |
| 39 | |
| 40 | delete_pkg_m4_file() { |
| 41 | # Delete m4 files which we provide patched versions of but will be ignored |
| 42 | # if these exist |
| 43 | rm -f "${S}/common/m4/pkg.m4" |
| 44 | rm -f "${S}/common/m4/gtk-doc.m4" |
| 45 | } |
| 46 | do_configure[prefuncs] += "delete_pkg_m4_file" |
| 47 | |
| 48 | set_omx_core_name() { |
| 49 | sed -i -e "s;^core-name=.*;core-name=${GSTREAMER_1_0_OMX_CORE_NAME};" "${D}${sysconfdir}/xdg/gstomx.conf" |
| 50 | } |
| 51 | do_install[postfuncs] += " set_omx_core_name " |
| 52 | |
| 53 | FILES_${PN} += "${libdir}/gstreamer-1.0/*.so" |
| 54 | FILES_${PN}-dev += "${libdir}/gstreamer-1.0/*.la" |
| 55 | FILES_${PN}-staticdev += "${libdir}/gstreamer-1.0/*.a" |
| 56 | |
| 57 | RDEPENDS_${PN} = "libomxil" |