blob: 2800a4c30f1f084e807d3a02f427f44992fb7d8e [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "File system QA test suite"
2LICENSE = "GPL-2.0-only"
3LIC_FILES_CHKSUM = "file://LICENSES/GPL-2.0;md5=74274e8a218423e49eefdea80bc55038"
4
Patrick Williams73bd93f2024-02-20 08:07:48 -06005SRCREV = "c46ca4d1f6c0c45f9a3ea18bc31ba5ae89e02c70"
Patrick Williamsac13d5f2023-11-24 18:59:46 -06006SRCREV_unionmount = "e3825b16b46f4c4574a1a69909944c059835f914"
Patrick Williams73bd93f2024-02-20 08:07:48 -06007SRCREV_FORMAT = "default_unionmount"
8
9SRC_URI = "git://git.kernel.org/pub/scm/fs/xfs/xfstests-dev.git;branch=master \
10 git://github.com/amir73il/unionmount-testsuite.git;branch=master;protocol=https;name=unionmount;destsuffix=unionmount-testsuite \
11 file://0001-add-missing-FTW_-macros-when-not-available-in-libc.patch \
12 file://0002-Drop-detached_mounts_propagation-and-remove-sys-moun.patch \
13 file://0003-tests-Makefile-make-sure-group.list-DIRT-exists-befo.patch \
14 "
Patrick Williamsac13d5f2023-11-24 18:59:46 -060015
16S = "${WORKDIR}/git"
17
Patrick Williams73bd93f2024-02-20 08:07:48 -060018# brokensep because m4/package_globals.m4 calls ". ./VERSION" (and that's not the only issue)
Patrick Williamsac13d5f2023-11-24 18:59:46 -060019inherit autotools-brokensep useradd
20
21DEPENDS += "xfsprogs acl"
22RDEPENDS:${PN} += "\
23 bash \
24 bc \
25 coreutils \
26 e2fsprogs \
27 e2fsprogs-tune2fs \
28 e2fsprogs-resize2fs \
29 libaio \
30 libcap-bin \
31 overlayfs-tools \
32 perl \
33 python3 \
34 python3-core \
35 xfsprogs \
36 acl \
Patrick Williams73bd93f2024-02-20 08:07:48 -060037 gawk \
Patrick Williamsac13d5f2023-11-24 18:59:46 -060038"
39
40USERADD_PACKAGES = "${PN}"
41# these users are necessary to run the tests
42USERADD_PARAM:${PN} = "-U -m fsgqa; -N 123456-fsgqa; -N fsgqa2"
43
44EXTRA_OECONF = "INSTALL_USER=root INSTALL_GROUP=root"
45
46TARGET_CC_ARCH:append:libc-musl = " -D_LARGEFILE64_SOURCE"
Patrick Williams73bd93f2024-02-20 08:07:48 -060047
Patrick Williamsac13d5f2023-11-24 18:59:46 -060048do_configure:prepend() {
Patrick Williams73bd93f2024-02-20 08:07:48 -060049 # this is done by Makefile configure target, but we don't call it in do_configure
50 cp -a ${S}/include/install-sh .
Patrick Williamsac13d5f2023-11-24 18:59:46 -060051}
52
Patrick Williams73bd93f2024-02-20 08:07:48 -060053do_install() {
54 # otherwise install-sh duplicates DESTDIR prefix
55 export DIST_ROOT="/" DIST_MANIFEST="" DESTDIR="${D}"
56 oe_runmake install
57
58 unionmount_target_dir=${D}${prefix}/xfstests/unionmount-testsuite
59 install -d $unionmount_target_dir/tests
60 install ${WORKDIR}/unionmount-testsuite/tests/* -t $unionmount_target_dir/tests
Patrick Williamsac13d5f2023-11-24 18:59:46 -060061 install ${WORKDIR}/unionmount-testsuite/*.py -t $unionmount_target_dir
62 install ${WORKDIR}/unionmount-testsuite/run -t $unionmount_target_dir
63 install ${WORKDIR}/unionmount-testsuite/README -t $unionmount_target_dir
64}
65
Patrick Williams73bd93f2024-02-20 08:07:48 -060066FILES:${PN} += "${prefix}/xfstests"