blob: 6d4d84e1e86179baccd54d8668497e6d306de29f [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "GNOME bluetooth manager"
2LICENSE = "GPL-2.0-only & LGPL-2.1-only"
3LIC_FILES_CHKSUM = " \
4 file://COPYING;md5=eb723b61539feef013de476e68b5c50a \
5 file://COPYING.LIB;md5=a6f89e2100d9b6cdffcea4f398e37343 \
6"
7
8SECTION = "x11/gnome"
9
10DEPENDS = " \
11 udev \
12 libnotify \
13 libcanberra \
14 bluez5 \
15 upower \
16 gtk4 \
17 gsound \
18 libadwaita \
19"
20
21GTKDOC_MESON_OPTION = "gtk_doc"
22GTKIC_VERSION = "4"
23
24inherit features_check gnomebase gtk-icon-cache gtk-doc gobject-introspection
25
26REQUIRED_DISTRO_FEATURES = "x11 opengl"
27
Patrick Williams39653562024-03-01 08:54:02 -060028SRC_URI[archive.sha256sum] = "76c241e8ca2c9b1035364535ca26084f89fc5c0e1829510f8909583115fcc2db"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060029
30BT_PULSE_PACKS = " \
31 pulseaudio-lib-bluez5-util \
32 pulseaudio-module-bluetooth-discover \
33 pulseaudio-module-bluetooth-policy \
34 pulseaudio-module-bluez5-device \
35 pulseaudio-module-bluez5-discover \
36"
37
38PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'pulseaudio', d)}"
39PACKAGECONFIG[pulseaudio] = ",,,${BT_PULSE_PACKS}"
40
41FILES:${PN} += "${datadir}/gnome-bluetooth-3.0"
42
43RDEPENDS:${PN} += "bluez5"