blob: 99cb9f67e7fd2437b863e665267f06efff8e9012 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "GNOME calendar"
2LICENSE = "GPL-3.0-only"
3LIC_FILES_CHKSUM = "file://COPYING;md5=8f0e2cd40e05189ec81232da84bd6e1a"
4
5SECTION = "x11/gnome"
6
7DEPENDS = " \
8 gtk4 \
9 libical \
10 gsettings-desktop-schemas \
11 evolution-data-server \
12 libsoup \
13 libdazzle \
14 libadwaita \
15 libgweather4 \
16 geoclue \
17 geocode-glib \
18"
19
20GTKIC_VERSION = '4'
21inherit gnomebase gsettings gtk-icon-cache gettext features_check upstream-version-is-even mime-xdg
22
23REQUIRED_DISTRO_FEATURES = "x11 opengl"
24
25SRC_URI[archive.sha256sum] = "7fa8507543865aa7432bb5319830c87158b5447ca09cca45b607dc6796c71008"
26
27do_install:prepend() {
28 sed -i -e 's|${S}/src|${TARGET_DBGSRC_DIR}/src|g' ${B}/src/gcal-enum-types.h
29 sed -i -e 's|${S}/src|${TARGET_DBGSRC_DIR}/src|g' ${B}/src/gcal-enum-types.c
30}
31
32FILES:${PN} += " \
33 ${datadir}/gnome-shell \
34 ${datadir}/metainfo \
35 ${datadir}/dbus-1 \
36"
37