blob: b90bbb8e5c0254b6bb27e86a5fe415797c787b9b [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "Gnome system monitor"
2LICENSE = "GPL-2.0-only"
3LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
4
5DEPENDS = " \
6 gnome-common-native \
7 libxml2-native \
8 glib-2.0-native \
9 gtkmm3 \
10 libgtop \
11 librsvg \
12 polkit \
13 libhandy \
14"
15
Andrew Geissler9aee5002022-03-30 16:27:02 +000016
17inherit gnomebase gsettings gnome-help itstool gtk-icon-cache features_check gettext
18
Andrew Geissler78b72792022-06-14 06:47:25 -050019ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
20REQUIRED_DISTRO_FEATURES = "polkit"
Andrew Geissler9aee5002022-03-30 16:27:02 +000021
22def gnome_verdir(v):
23 return oe.utils.trim_version(v, 1)
24
Andrew Geissler220dafd2023-10-04 10:18:08 -050025SRC_URI[archive.sha256sum] = "43f6b7805c74532490edb8822ebdf8b3cf2c5ef842a51252a14c34715f5d49b4"
Andrew Geissler9aee5002022-03-30 16:27:02 +000026
27PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
28PACKAGECONFIG[systemd] = "-Dsystemd=true, -Dsystemd=false, systemd"
29
30RRECOMMENDS:${PN} = "adwaita-icon-theme"
31
32FILES:${PN} += " \
33 ${datadir}/dbus-1 \
34 ${datadir}/metainfo \
35"