blob: 71d738ddc13c24bf58852d1d72f734378a5846a5 [file] [log] [blame]
Andrew Geissler87f5cff2022-09-30 13:13:31 -05001SUMMARY = "Open-LLDP"
2DESCRIPTION = "Link Layer Discovery Protocol for Linux that includes support for DCBX"
3HOMEPAGE = "http://open-lldp.org/start"
4
5LICENSE = "GPL-2.0-only"
6LIC_FILES_CHKSUM = "file://COPYING;md5=8c2bc283e65df398ced5f5b747e78162"
7
8S = "${WORKDIR}/git"
9
10inherit pkgconfig autotools
11inherit ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}
12
13DEPENDS = "libnl libconfig readline"
14
15SRCREV = "85e55837a81d710e5baa7da47f7ed0d205c8ede5"
Patrick Williams73bd93f2024-02-20 08:07:48 -060016PV .= "+git"
Andrew Geissler87f5cff2022-09-30 13:13:31 -050017SRC_URI = "git://github.com/intel/openlldp.git;protocol=https;branch=branch-1.1 \
18 file://0001-Fix-musl-libc-build-issue.patch \
19 file://0001-autotools-Add-include-path-to-generated-version.h.patch \
20 file://0001-autotools-Add-option-to-disable-installation-of-syst.patch \
21 file://0004-clif-Include-string.h-for-mem-function-prototypes.patch \
22 "
23
24# Enable install of systemd conf files.
25EXTRA_OECONF += "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '--with-systemdsystemunitdir=${systemd_system_unitdir}', '', d)}"
26
27SYSTEMD_SERVICE:${PN} = "lldpad.service lldpad.socket"
28
29# To enable service at boot set to enable in local.conf.
30SYSTEMD_AUTO_ENABLE ?= "disable"
31
32RRECOMMENDS:${PN} = "iproute2-tc"