blob: 234ecfae0c6bb6ce3891958fb67d4b4f3896edbe [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "WebKit web rendering engine for the GTK+ platform"
2HOMEPAGE = "https://www.webkitgtk.org/"
3BUGTRACKER = "https://bugs.webkit.org/"
4
5LICENSE = "BSD-2-Clause & LGPL-2.0-or-later"
6LIC_FILES_CHKSUM = "file://Source/JavaScriptCore/COPYING.LIB;md5=d0c6d6397a5d84286dda758da57bd691 \
7 file://Source/WebCore/LICENSE-APPLE;md5=4646f90082c40bcf298c285f8bab0b12 \
8 file://Source/WebCore/LICENSE-LGPL-2;md5=36357ffde2b64ae177b2494445b79d21 \
9 file://Source/WebCore/LICENSE-LGPL-2.1;md5=a778a33ef338abbaf8b8a7c36b6eec80 \
10 "
11
12SRC_URI = "https://www.webkitgtk.org/releases/webkitgtk-${PV}.tar.xz \
13 file://0001-FindGObjectIntrospection.cmake-prefix-variables-obta.patch \
14 file://reproducibility.patch \
15 file://0d3344e17d258106617b0e6d783d073b188a2548.patch \
16 file://no-musttail-arm.patch \
Patrick Williams39653562024-03-01 08:54:02 -060017 file://0001-LowLevelInterpreter.cpp-339-21-error-t6-was-not-decl.patch \
Patrick Williamsac13d5f2023-11-24 18:59:46 -060018 "
Patrick Williams39653562024-03-01 08:54:02 -060019SRC_URI[sha256sum] = "b64278c1f20b8cfdbfb5ff573c37d871aba74a1db26d9b39f74e8953fe61e749"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060020
21inherit cmake pkgconfig gobject-introspection perlnative features_check upstream-version-is-even gi-docgen
22
23S = "${WORKDIR}/webkitgtk-${PV}"
24
25ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
26REQUIRED_DISTRO_FEATURES = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'opengl', '', d)}"
27
28CVE_PRODUCT = "webkitgtk webkitgtk\+"
29
30DEPENDS += " \
31 ruby-native \
32 gperf-native \
33 unifdef-native \
34 cairo \
35 harfbuzz \
36 jpeg \
37 atk \
38 libwebp \
39 gtk+3 \
40 libxslt \
41 libtasn1 \
42 libnotify \
43 gstreamer1.0 \
44 gstreamer1.0-plugins-base \
45 glib-2.0-native \
46 gettext-native \
47 "
48
49PACKAGECONFIG_SOUP ?= "soup3"
50PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd wayland x11', d)} \
51 ${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'webgl opengl', '', d)} \
52 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', 'webgl gles2', d)} \
53 ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'opengl-or-es', '', d)} \
54 enchant \
55 libsecret \
56 ${PACKAGECONFIG_SOUP} \
57 "
58
59PACKAGECONFIG[wayland] = "-DENABLE_WAYLAND_TARGET=ON,-DENABLE_WAYLAND_TARGET=OFF,wayland libwpe wpebackend-fdo wayland-native"
60PACKAGECONFIG[angle] = "-DUSE_ANGLE_WEBGL=ON,-DUSE_ANGLE_WEBGL=OFF"
61PACKAGECONFIG[x11] = "-DENABLE_X11_TARGET=ON,-DENABLE_X11_TARGET=OFF,virtual/libx11 libxcomposite libxdamage libxrender libxt"
62PACKAGECONFIG[geoclue] = "-DENABLE_GEOLOCATION=ON,-DENABLE_GEOLOCATION=OFF,geoclue"
63PACKAGECONFIG[enchant] = "-DENABLE_SPELLCHECK=ON,-DENABLE_SPELLCHECK=OFF,enchant2"
64PACKAGECONFIG[gles2] = "-DENABLE_GLES2=ON,-DENABLE_GLES2=OFF,virtual/libgles2"
65PACKAGECONFIG[jpegxl] = " -DUSE_JPEGXL=ON,-DUSE_JPEGXL=OFF,libjxl"
66PACKAGECONFIG[webgl] = "-DENABLE_WEBGL=ON,-DENABLE_WEBGL=OFF,virtual/egl"
67PACKAGECONFIG[opengl] = "-DENABLE_GRAPHICS_CONTEXT_GL=ON,-DENABLE_GRAPHICS_CONTEXT_GL=OFF,virtual/egl"
68PACKAGECONFIG[opengl-or-es] = "-DUSE_OPENGL_OR_ES=ON,-DUSE_OPENGL_OR_ES=OFF"
69PACKAGECONFIG[libsecret] = "-DUSE_LIBSECRET=ON,-DUSE_LIBSECRET=OFF,libsecret"
70PACKAGECONFIG[libhyphen] = "-DUSE_LIBHYPHEN=ON,-DUSE_LIBHYPHEN=OFF,libhyphen"
71PACKAGECONFIG[woff2] = "-DUSE_WOFF2=ON,-DUSE_WOFF2=OFF,woff2"
72PACKAGECONFIG[openjpeg] = "-DUSE_OPENJPEG=ON,-DUSE_OPENJPEG=OFF,openjpeg"
73PACKAGECONFIG[systemd] = "-DUSE_SYSTEMD=ON,-DUSE_SYSTEMD=off,systemd"
74PACKAGECONFIG[reduce-size] = "-DCMAKE_BUILD_TYPE=MinSizeRel,-DCMAKE_BUILD_TYPE=Release,,"
75PACKAGECONFIG[lcms] = "-DUSE_LCMS=ON,-DUSE_LCMS=OFF,lcms"
76PACKAGECONFIG[soup2] = "-DUSE_SOUP2=ON,-DUSE_SOUP2=OFF,libsoup-2.4,,,soup3"
77PACKAGECONFIG[soup3] = ",,libsoup,,,soup2"
78PACKAGECONFIG[journald] = "-DENABLE_JOURNALD_LOG=ON,-DENABLE_JOURNALD_LOG=OFF,systemd"
79PACKAGECONFIG[avif] = "-DUSE_AVIF_LOG=ON,-DUSE_AVIF=OFF,libavif"
80PACKAGECONFIG[media-recorder] = "-DENABLE_MEDIA_RECORDER=ON,-DENABLE_MEDIA_RECORDER=OFF,gstreamer1.0-plugins-bad"
81PACKAGECONFIG[gamepad] = "-DENABLE_GAMEPAD=ON,-DENABLE_GAMEPAD=OFF,libmanette"
82PACKAGECONFIG[webrtc] = "-DENABLE_WEB_RTC=ON,-DENABLE_WEB_RTC=OFF"
83PACKAGECONFIG[bubblewrap] = "-DENABLE_BUBBLEWRAP_SANDBOX=ON -DBWRAP_EXECUTABLE=${bindir}/bwrap -DDBUS_PROXY_EXECUTABLE=${bindir}/xdg-dbus-proxy,-DENABLE_BUBBLEWRAP_SANDBOX=OFF,,bubblewrap xdg-dbus-proxy"
84
85EXTRA_OECMAKE = " \
86 -DPORT=GTK \
87 ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '-DENABLE_INTROSPECTION=ON', '-DENABLE_INTROSPECTION=OFF', d)} \
88 ${@bb.utils.contains('GIDOCGEN_ENABLED', 'True', '-DENABLE_DOCUMENTATION=ON', '-DENABLE_DOCUMENTATION=OFF', d)} \
89 -DENABLE_MINIBROWSER=ON \
90 "
91# Unless DEBUG_BUILD is enabled, pass -g1 to massively reduce the size of the
92# debug symbols (4.3GB to 700M at time of writing)
93DEBUG_FLAGS:append = "${@oe.utils.vartrue('DEBUG_BUILD', '', ' -g1', d)}"
94
95# Javascript JIT is not supported on ARC
96EXTRA_OECMAKE:append:arc = " -DENABLE_JIT=OFF "
97# By default 25-bit "medium" calls are used on ARC
98# which is not enough for binaries larger than 32 MiB
99CFLAGS:append:arc = " -mlong-calls"
100CXXFLAGS:append:arc = " -mlong-calls"
101
102# Needed for non-mesa graphics stacks when x11 is disabled
103CXXFLAGS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', '-DEGL_NO_X11=1', d)}"
104
105# Javascript JIT is not supported on powerpc
106EXTRA_OECMAKE:append:powerpc = " -DENABLE_JIT=OFF "
107EXTRA_OECMAKE:append:powerpc64 = " -DENABLE_JIT=OFF "
108
109# ARM JIT code does not build on ARMv4/5/6 anymore
110EXTRA_OECMAKE:append:armv4 = " -DENABLE_JIT=OFF "
111EXTRA_OECMAKE:append:armv5 = " -DENABLE_JIT=OFF "
112EXTRA_OECMAKE:append:armv6 = " -DENABLE_JIT=OFF "
113
114# And for armv7* don't enable it for softfp, because after:
115# https://github.com/WebKit/WebKit/commit/a2ec4ef1997d6fafa6ffc607bffb54e76168a918
116# https://bugs.webkit.org/show_bug.cgi?id=242172
117# softfp armv7* fails because WEBASSEMBLY is left enabled by default and JIT gets
118# explicitly disabled causing:
119# http://errors.yoctoproject.org/Errors/Details/734587/
120# PR was sent upstream, but the end result is the same both JIT and WEBASSEMBLY disabled
121# https://github.com/WebKit/WebKit/pull/17447
122EXTRA_OECMAKE:append:armv7a = " -DENABLE_JIT=${@bb.utils.contains('TUNE_FEATURES', 'callconvention-hard', 'ON', 'OFF', d)}"
123EXTRA_OECMAKE:append:armv7r = " -DENABLE_JIT=${@bb.utils.contains('TUNE_FEATURES', 'callconvention-hard', 'ON', 'OFF', d)}"
124EXTRA_OECMAKE:append:armv7ve = " -DENABLE_JIT=${@bb.utils.contains('TUNE_FEATURES', 'callconvention-hard', 'ON', 'OFF', d)}"
125
126EXTRA_OECMAKE:append:mipsarch = " -DUSE_LD_GOLD=OFF "
127EXTRA_OECMAKE:append:powerpc = " -DUSE_LD_GOLD=OFF "
128
129# JIT and gold linker does not work on RISCV
130EXTRA_OECMAKE:append:riscv32 = " -DUSE_LD_GOLD=OFF -DENABLE_JIT=OFF"
131EXTRA_OECMAKE:append:riscv64 = " -DUSE_LD_GOLD=OFF"
132
133# JIT not supported on MIPS either
134EXTRA_OECMAKE:append:mipsarch = " -DENABLE_JIT=OFF -DENABLE_C_LOOP=ON "
135
136# JIT not supported on X32
137# An attempt was made to upstream JIT support for x32 in
138# https://bugs.webkit.org/show_bug.cgi?id=100450, but this was closed as
139# unresolved due to limited X32 adoption.
140EXTRA_OECMAKE:append:x86-x32 = " -DENABLE_JIT=OFF "
141
142SECURITY_CFLAGS:remove:aarch64 = "-fpie"
143SECURITY_CFLAGS:append:aarch64 = " -fPIE"
144
145FILES:${PN} += "${libdir}/webkit2gtk-4.*/injected-bundle/libwebkit2gtkinjectedbundle.so"
146
147RRECOMMENDS:${PN} += "ca-certificates shared-mime-info"
148
149# http://errors.yoctoproject.org/Errors/Details/20370/
150ARM_INSTRUCTION_SET:armv4 = "arm"
151ARM_INSTRUCTION_SET:armv5 = "arm"
152ARM_INSTRUCTION_SET:armv6 = "arm"
153
154# https://bugzilla.yoctoproject.org/show_bug.cgi?id=9474
155# https://bugs.webkit.org/show_bug.cgi?id=159880
156# JSC JIT can build on ARMv7 with -marm, but doesn't work on runtime.
157# Upstream only tests regularly the JSC JIT on ARMv7 with Thumb2 (-mthumb).
158ARM_INSTRUCTION_SET:armv7a = "thumb"
159ARM_INSTRUCTION_SET:armv7r = "thumb"
160ARM_INSTRUCTION_SET:armv7ve = "thumb"
161
162# ANGLE requires SSE support as of webkit 2.40.x on 32 bit x86
163COMPATIBLE_HOST:x86 = "${@bb.utils.contains_any('TUNE_FEATURES', 'core2 corei7', '.*', 'null', d)}"
164
165# introspection inside qemu-arm hangs forever on musl/arm builds
166# therefore disable GI_DATA
167GI_DATA_ENABLED:libc-musl:armv7a = "False"
168GI_DATA_ENABLED:libc-musl:armv7ve = "False"
169
170do_install:append() {
171 mv ${D}${bindir}/WebKitWebDriver ${D}${bindir}/WebKitWebDriver3
172}
173
174PACKAGE_PREPROCESS_FUNCS += "src_package_preprocess"
175src_package_preprocess () {
176 # Trim build paths from comments in generated sources to ensure reproducibility
177 sed -i -e "s,${WORKDIR},,g" \
178 ${B}/JavaScriptCore/DerivedSources/*.h \
179 ${B}/JavaScriptCore/DerivedSources/yarr/*.h \
180 ${B}/JavaScriptCore/PrivateHeaders/JavaScriptCore/*.h \
181 ${B}/WebCore/DerivedSources/*.cpp \
182 ${B}/WebKitGTK/DerivedSources/webkit/*.cpp
183}
184