blob: 50b1340cb312ce2a9593320f2985ca748d407299 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "Python utilities for working with Ethereum ABI definitions, especially encoding and decoding."
2HOMEPAGE = "https://github.com/ethereum/eth-abi"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=731f4de9c79bfeba6d8d55f83d0d2423"
6
Patrick Williams73bd93f2024-02-20 08:07:48 -06007SRC_URI[sha256sum] = "89c4454d794d9ed92ad5cb2794698c5cee6b7b3ca6009187d0e282adc7f9b6dc"
Patrick Williamsac13d5f2023-11-24 18:59:46 -06008
9PYPI_PACKAGE = "eth_abi"
10
11inherit pypi setuptools3
12
13RDEPENDS:${PN} += " \
14 python3-eth-typing \
15 python3-eth-utils \
16 python3-parsimonious \
17 python3-setuptools \
18"