blob: 4f53d01f372973310ac05694cc644c916c80b57a [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "A fully featured modbus protocol stack in python"
2HOMEPAGE = "https://github.com/riptideio/pymodbus/"
3LICENSE = "BSD-3-Clause"
Patrick Williams73bd93f2024-02-20 08:07:48 -06004LIC_FILES_CHKSUM = "file://LICENSE;md5=eba8057aa82c058d2042b4b0a0e9cc63"
Andrew Geissler517393d2023-01-13 08:55:19 -06005
Patrick Williams39653562024-03-01 08:54:02 -06006SRC_URI[sha256sum] = "6eee2c7eedb794317784c967096fa1fe42200357e9b5a349d838ee9159624fe2"
Andrew Geissler517393d2023-01-13 08:55:19 -06007
Patrick Williams73bd93f2024-02-20 08:07:48 -06008inherit pypi python_setuptools_build_meta
Andrew Geissler517393d2023-01-13 08:55:19 -06009
10PACKAGECONFIG ??= ""
11PACKAGECONFIG[repl] = ",,,python3-aiohttp python3-click python3-prompt-toolkit python3-pygments python3-pyserial-asyncio"
12PACKAGECONFIG[asyncio] = ",,,python3-pyserial-asyncio"
13PACKAGECONFIG[tornado] = ",,,python3-tornado"
14PACKAGECONFIG[twisted] = ",,,python3-twisted-conch"
15PACKAGECONFIG[redis] = ",,,python3-redis"
16PACKAGECONFIG[sql] = ",,,python3-sqlalchemy"
17
18RDEPENDS:${PN} += " \
19 python3-asyncio \
20 python3-core \
21 python3-io \
22 python3-json \
23 python3-logging \
24 python3-math \
25 python3-netserver \
26"
27
28RDEPENDS:${PN} += " \
29 python3-pyserial \
30 python3-six \
31"