blob: 84c61ec8b01cf0f891f88cbf8de8e38f26385efa [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "A toolkit to write, run and analyze benchmarks"
2DESCRIPTION = " \
3The Python pyperf module is a toolkit to write, run and analyze benchmarks. \
4Features: \
5 * Simple API to run reliable benchmarks \
6 * Automatically calibrate a benchmark for a time budget. \
7 * Spawn multiple worker processes. \
8 * Compute the mean and standard deviation. \
9 * Detect if a benchmark result seems unstable. \
10 * JSON format to store benchmark results. \
11 * Support multiple units: seconds, bytes and integer. \
12"
13LICENSE = "MIT"
14LIC_FILES_CHKSUM = "file://COPYING;md5=78bc2e6e87c8c61272937b879e6dc2f8"
15
16SRC_URI[sha256sum] = "64d8fadce6a74f478f29832c1eaa2a04856655ebff17292d5237fc8317c3a3c5"
17
Patrick Williams39653562024-03-01 08:54:02 -060018DEPENDS += "python3-six-native"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060019
20PYPI_PACKAGE = "pyperf"
21inherit pypi python_setuptools_build_meta
22
Patrick Williams39653562024-03-01 08:54:02 -060023RDEPENDS:${PN} += "python3-misc python3-statistics"