blob: fa3a3c66b1b6aec239e65931e00c83fd76ae2543 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001From 77cb4a53c270d5854d3af24f19547bc3de825233 Mon Sep 17 00:00:00 2001
2From: James Cowgill <james410@cowgill.org.uk>
3Date: Mon, 5 Jan 2015 15:16:58 +0000
4Subject: [PATCH 1/3] Ignore differences between mips machine identifiers
5
6Little endian binaries actually use EM_MIPS so you can't tell the endianness
7from the elf machine id. Also, the EM_MIPS_RS3_LE machine is dead anyway (the
8kernel will not load binaries containing it).
9
10Signed-off-by: James Cowgill <james410@cowgill.org.uk>
Brad Bishopa5c52ff2018-11-23 10:55:50 +130011Upstream-Status: Pending [from debian]
12Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
Brad Bishop6e60e8b2018-02-01 10:27:11 -050013---
14 backends/mips_init.c | 6 +-----
15 1 file changed, 1 insertion(+), 5 deletions(-)
16
17Index: b/backends/mips_init.c
18===================================================================
19--- a/backends/mips_init.c
20+++ b/backends/mips_init.c
21@@ -45,11 +45,7 @@ mips_init (Elf *elf __attribute__ ((unus
22 return NULL;
23
24 /* We handle it. */
25- if (machine == EM_MIPS)
26- eh->name = "MIPS R3000 big-endian";
27- else if (machine == EM_MIPS_RS3_LE)
28- eh->name = "MIPS R3000 little-endian";
29-
30+ eh->name = "MIPS";
31 mips_init_reloc (eh);
32 HOOK (eh, reloc_simple_type);
33 HOOK (eh, return_value_location);