blob: fe5159f3c2be1ff1d538b001f0b6911cdac5b7a6 [file] [log] [blame]
Brad Bishopa5c52ff2018-11-23 10:55:50 +13001Upstream-Status: Pending [from debian]
2Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
3Index: b/tests/run-native-test.sh
4===================================================================
5--- a/tests/run-native-test.sh
6+++ b/tests/run-native-test.sh
7@@ -77,6 +77,12 @@ native_test()
8 test $native -eq 0 || testrun "$@" -p $native > /dev/null
9 }
10
11+# On the Debian buildds, GNU/kFreeBSD linprocfs /proc/$PID/maps does
12+# not give absolute paths due to sbuild's bind mounts (bug #570805)
13+# therefore the next two test programs are expected to fail with
14+# "cannot attach to process: Function not implemented".
15+[ "$(uname)" = "GNU/kFreeBSD" ] && exit 77
16+
17 native_test ${abs_builddir}/allregs
18 native_test ${abs_builddir}/funcretval
19