blob: d26e72e28c24fb4ff7b0a01b3804bc3f305327e5 [file] [log] [blame]
Brad Bishopa5c52ff2018-11-23 10:55:50 +13001From: Kurt Roeckx <kurt@roeckx.be>
2Subject: Make readelf -w output debug information on mips
3Bug-Debian: http://bugs.debian.org/662041
4Forwarded: not-needed
5
6Upstreams wants a change where this is handled by a hook that needs
7to be filled in by the backend for the arch.
8
9Upstream-Status: Pending [from debian]
10Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
11
12Index: elfutils-0.175/src/readelf.c
13===================================================================
14--- elfutils-0.175.orig/src/readelf.c
15+++ elfutils-0.175/src/readelf.c
16@@ -11133,7 +11133,8 @@ print_debug (Dwfl_Module *dwflmod, Ebl *
17 GElf_Shdr shdr_mem;
18 GElf_Shdr *shdr = gelf_getshdr (scn, &shdr_mem);
19
20- if (shdr != NULL && shdr->sh_type == SHT_PROGBITS)
21+ if (shdr != NULL && (
22+ (shdr->sh_type == SHT_PROGBITS) || (shdr->sh_type == SHT_MIPS_DWARF)))
23 {
24 static const struct
25 {