blob: 4c41774c39279f9996ad5c3da8fa116ddb9190ed [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "Additional utilities for the opkg package manager"
2SUMMARY_update-alternatives-opkg = "Utility for managing the alternatives system"
3SECTION = "base"
4HOMEPAGE = "http://git.yoctoproject.org/cgit/cgit.cgi/opkg-utils"
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
7 file://opkg.py;beginline=2;endline=18;md5=63ce9e6bcc445181cd9e4baf4b4ccc35"
8PROVIDES += "${@bb.utils.contains('PACKAGECONFIG', 'update-alternatives', 'virtual/update-alternatives', '', d)}"
9
10SRC_URI = "http://git.yoctoproject.org/cgit/cgit.cgi/${BPN}/snapshot/${BPN}-${PV}.tar.gz \
11 file://0001-Switch-all-scripts-to-use-Python-3.x.patch \
12 file://0001-Only-use-sort-name-on-versions-of-tar-which-support-.patch \
13 file://0002-opkg-build-Use-local-time-for-build_date-since-opkg-.patch \
14 file://threaded-xz.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080015 file://pigz.patch \
Brad Bishopa5c52ff2018-11-23 10:55:50 +130016 file://0001-update-alternatives-Fix-link-relocation-support.patch \
Brad Bishop316dfdd2018-06-25 12:45:53 -040017"
18SRC_URI_append_class-native = " file://tar_ignore_error.patch"
19UPSTREAM_CHECK_URI = "http://git.yoctoproject.org/cgit/cgit.cgi/opkg-utils/refs/"
20
21
22SRC_URI[md5sum] = "391c1c80aca26961375dd22e1d2d0cbf"
23SRC_URI[sha256sum] = "26b3f4dd1c1ef65f519d4cddfb35ebea41ae8af989aea2699a39783598c33769"
24
25TARGET_CC_ARCH += "${LDFLAGS}"
26
27# For native builds we use the host Python
28PYTHONRDEPS = "python3 python3-shell python3-io python3-math python3-crypt python3-logging python3-fcntl python3-pickle python3-compression python3-stringold"
29PYTHONRDEPS_class-native = ""
30
31PACKAGECONFIG = "python update-alternatives"
32PACKAGECONFIG[python] = ",,,${PYTHONRDEPS}"
33PACKAGECONFIG[update-alternatives] = ",,,"
34
35do_install() {
36 oe_runmake PREFIX=${prefix} DESTDIR=${D} install
37 if ! ${@bb.utils.contains('PACKAGECONFIG', 'update-alternatives', 'true', 'false', d)}; then
38 rm -f "${D}${bindir}/update-alternatives"
39 fi
40
41 if ! ${@bb.utils.contains('PACKAGECONFIG', 'python', 'true', 'false', d)}; then
42 grep -lZ "/usr/bin/env.*python" ${D}${bindir}/* | xargs -0 rm
43 fi
44}
45
46do_install_append_class-target() {
47 if [ -e "${D}${bindir}/update-alternatives" ]; then
48 sed -i ${D}${bindir}/update-alternatives -e 's,/usr/bin,${bindir},g; s,/usr/lib,${nonarch_libdir},g'
49 fi
50}
51
52# These are empty and will pull python3-dev into images where it wouldn't
53# have been otherwise, so don't generate them.
54PACKAGES_remove = "${PN}-dev ${PN}-staticdev"
55
56PACKAGES =+ "update-alternatives-opkg"
57FILES_update-alternatives-opkg = "${bindir}/update-alternatives"
58RPROVIDES_update-alternatives-opkg = "update-alternatives update-alternatives-cworth"
59RREPLACES_update-alternatives-opkg = "update-alternatives-cworth"
60RCONFLICTS_update-alternatives-opkg = "update-alternatives-cworth"
61
62pkg_postrm_update-alternatives-opkg() {
63 rm -rf $D${nonarch_libdir}/opkg/alternatives
64 rmdir $D${nonarch_libdir}/opkg || true
65}
66
67BBCLASSEXTEND = "native nativesdk"
68
69CLEANBROKEN = "1"