blob: 50f8221ebb8cd6a521ea6b8efc1ffe8cbb7c0b0a [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Valgrind memory debugger and instrumentation framework"
2HOMEPAGE = "http://valgrind.org/"
3BUGTRACKER = "http://valgrind.org/support/bug_reports.html"
4LICENSE = "GPLv2 & GPLv2+ & BSD"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
6 file://include/pub_tool_basics.h;beginline=6;endline=29;md5=d4de0407239381463cf01dd276d7c22e \
7 file://include/valgrind.h;beginline=1;endline=56;md5=ad3b317f3286b6b704575d9efe6ca5df \
8 file://COPYING.DOCS;md5=24ea4c7092233849b4394699333b5c56"
9
10X11DEPENDS = "virtual/libx11"
11DEPENDS = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', '${X11DEPENDS}', '', d)} \
12 ${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'boost', '', d)} \
13 "
14
15SRC_URI = "http://www.valgrind.org/downloads/valgrind-${PV}.tar.bz2 \
16 file://fixed-perl-path.patch \
17 file://Added-support-for-PPC-instructions-mfatbu-mfatbl.patch \
18 file://run-ptest \
19 file://0004-Fix-out-of-tree-builds.patch \
20 file://0005-Modify-vg_test-wrapper-to-support-PTEST-formats.patch \
21 file://0001-Remove-tests-that-fail-to-build-on-some-PPC32-config.patch \
22 file://use-appropriate-march-mcpu-mfpu-for-ARM-test-apps.patch \
23 file://avoid-neon-for-targets-which-don-t-support-it.patch \
24 file://valgrind-make-ld-XXX.so-strlen-intercept-optional.patch \
25 file://0001-makefiles-Drop-setting-mcpu-to-cortex-a8-on-arm-arch.patch \
26 file://0001-str_tester.c-Limit-rawmemchr-test-to-glibc.patch \
27 file://0001-sigqueue-Rename-_sifields-to-__si_fields-on-musl.patch \
28 file://0002-context-APIs-are-not-available-on-musl.patch \
29 file://0003-correct-include-directive-path-for-config.h.patch \
30 file://0004-pth_atfork1.c-Define-error-API-for-musl.patch \
31 file://0005-tc20_verifywrap.c-Fake-__GLIBC_PREREQ-with-musl.patch \
32 file://0006-pth_detached3.c-Dereference-pthread_t-before-adding-.patch \
33 file://0001-memcheck-arm64-Define-__THROW-if-not-already-defined.patch \
34 file://0002-memcheck-x86-Define-__THROW-if-not-defined.patch \
35 file://0003-tests-seg_override-Replace-__modify_ldt-with-syscall.patch \
36 file://0001-fix-opcode-not-supported-on-mips32-linux.patch \
37 file://0001-Guard-against-__GLIBC_PREREQ-for-musl-libc.patch \
38 file://0001-Make-local-functions-static-to-avoid-assembler-error.patch \
39 "
40SRC_URI[md5sum] = "74175426afa280184b62591b58c671b3"
41SRC_URI[sha256sum] = "037c11bfefd477cc6e9ebe8f193bb237fe397f7ce791b4a4ce3fa1c6a520baa5"
42UPSTREAM_CHECK_REGEX = "valgrind-(?P<pver>\d+(\.\d+)+)\.tar"
43
44COMPATIBLE_HOST = '(i.86|x86_64|arm|aarch64|mips|powerpc|powerpc64).*-linux'
45
46# valgrind supports armv7 and above
47COMPATIBLE_HOST_armv4 = 'null'
48COMPATIBLE_HOST_armv5 = 'null'
49COMPATIBLE_HOST_armv6 = 'null'
50
51# X32 isn't supported by valgrind at this time
52COMPATIBLE_HOST_linux-gnux32 = 'null'
53COMPATIBLE_HOST_linux-muslx32 = 'null'
54
55# Disable for some MIPS variants
56COMPATIBLE_HOST_mipsarchr6 = 'null'
57COMPATIBLE_HOST_linux-gnun32 = 'null'
58
59inherit autotools ptest multilib_header
60
61EXTRA_OECONF = "--enable-tls --without-mpicc"
62EXTRA_OECONF += "${@['--enable-only32bit','--enable-only64bit'][d.getVar('SITEINFO_BITS') != '32']}"
63
64# valgrind checks host_cpu "armv7*)", so we need to over-ride the autotools.bbclass default --host option
65EXTRA_OECONF_append_arm = " --host=armv7${HOST_VENDOR}-${HOST_OS}"
66TARGET_CC_ARCH_remove_arm = "${@get_mcpu(d)}"
67
68EXTRA_OEMAKE = "-w"
69
70CACHED_CONFIGUREVARS += "ac_cv_path_PERL='/usr/bin/env perl'"
71
72# valgrind likes to control its own optimisation flags. It generally defaults
73# to -O2 but uses -O0 for some specific test apps etc. Passing our own flags
74# (via CFLAGS) means we interfere with that. Only pass DEBUG_FLAGS to it
75# which fixes build path issue in DWARF.
76SELECTED_OPTIMIZATION = "${DEBUG_FLAGS}"
77
78def get_mcpu(d):
79 for arg in (d.getVar('TUNE_CCARGS') or '').split():
80 if arg.startswith('-mcpu='):
81 return arg
82 else:
83 continue
84 return ""
85
86do_configure_prepend () {
87 rm -rf ${S}/config.h
88 sed -i -e 's:$(abs_top_builddir):$(pkglibdir)/ptest:g' ${S}/none/tests/Makefile.am
89 sed -i -e 's:$(top_builddir):$(pkglibdir)/ptest:g' ${S}/memcheck/tests/Makefile.am
90}
91
92do_install_append () {
93 install -m 644 ${B}/default.supp ${D}/${libdir}/valgrind/
94 oe_multilib_header valgrind/config.h
95}
96
97TUNE = "${@strip_mcpu(d)}"
98
Brad Bishopa5c52ff2018-11-23 10:55:50 +130099VALGRINDARCH ?= "${TARGET_ARCH}"
100VALGRINDARCH_aarch64 = "arm64"
101VALGRINDARCH_x86-64 = "amd64"
102VALGRINDARCH_x86 = "x86"
103VALGRINDARCH_mips = "mips32"
104VALGRINDARCH_mipsel = "mips32"
105VALGRINDARCH_mips64el = "mips64"
106VALGRINDARCH_powerpc = "ppc"
107VALGRINDARCH_powerpc64 = "ppc64"
108VALGRINDARCH_powerpc64el = "ppc64le"
109
110INHIBIT_PACKAGE_STRIP_FILES = "${PKGD}${libdir}/valgrind/vgpreload_memcheck-${VALGRINDARCH}-linux.so"
111
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800112RDEPENDS_${PN} += "perl"
113
114# valgrind needs debug information for ld.so at runtime in order to
115# redirect functions like strlen.
116RRECOMMENDS_${PN} += "${TCLIBC}-dbg"
117
118RDEPENDS_${PN}-ptest += " sed perl perl-module-file-glob"
119RDEPENDS_${PN}-ptest_append_libc-glibc = " glibc-utils"
120
121# One of the tests contains a bogus interpreter path on purpose.
122# Skip file dependency check
123SKIP_FILEDEPS_${PN}-ptest = '1'
124
125do_compile_ptest() {
126 oe_runmake check
127}
128
129do_install_ptest() {
130 chmod +x ${B}/tests/vg_regtest
131
132 # The test application binaries are not automatically installed.
133 # Grab them from the build directory.
134 #
135 # The regression tests require scripts and data files that are not
136 # copied to the build directory. They must be copied from the
137 # source directory.
138 saved_dir=$PWD
139 for parent_dir in ${S} ${B} ; do
140 cd $parent_dir
141
142 # exclude shell or the package won't install
143 rm -rf none/tests/shell* 2>/dev/null
144
145 subdirs="tests cachegrind/tests callgrind/tests drd/tests helgrind/tests massif/tests memcheck/tests none/tests"
146
147 # Get the vg test scripts, filters, and expected files
148 for dir in $subdirs ; do
149 find $dir | cpio -pvdu ${D}${PTEST_PATH}
150 done
151 cd $saved_dir
152 done
153
154 # clean out build artifacts before building the rpm
155 find ${D}${PTEST_PATH} \
156 \( -name "Makefile*" \
157 -o -name "*.o" \
158 -o -name "*.c" \
159 -o -name "*.S" \
160 -o -name "*.h" \) \
161 -exec rm {} \;
162
163 # needed by massif tests
164 cp ${B}/massif/ms_print ${D}${PTEST_PATH}/massif/ms_print
165
166 # handle multilib
167 sed -i s:@libdir@:${libdir}:g ${D}${PTEST_PATH}/run-ptest
168}