Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Display or change ethernet card settings" |
| 2 | DESCRIPTION = "A small utility for examining and tuning the settings of your ethernet-based network interfaces." |
| 3 | HOMEPAGE = "http://www.kernel.org/pub/software/network/ethtool/" |
| 4 | SECTION = "console/network" |
| 5 | LICENSE = "GPLv2+" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| 7 | file://ethtool.c;beginline=4;endline=17;md5=c19b30548c582577fc6b443626fc1216" |
| 8 | |
| 9 | SRC_URI = "${KERNELORG_MIRROR}/software/network/ethtool/ethtool-${PV}.tar.gz \ |
| 10 | file://run-ptest \ |
| 11 | file://avoid_parallel_tests.patch \ |
| 12 | " |
| 13 | |
Brad Bishop | a5c52ff | 2018-11-23 10:55:50 +1300 | [diff] [blame^] | 14 | SRC_URI[md5sum] = "a533db1d202724822c4ef297643fac12" |
| 15 | SRC_URI[sha256sum] = "e8e88f5a79c78e542cd84fee60b67dbf29cee63e4760e8d61544fea74c761ad1" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 16 | |
| 17 | inherit autotools ptest |
| 18 | RDEPENDS_${PN}-ptest += "make" |
| 19 | |
| 20 | do_compile_ptest() { |
| 21 | oe_runmake buildtest-TESTS |
| 22 | } |
| 23 | |
| 24 | do_install_ptest () { |
| 25 | cp ${B}/Makefile ${D}${PTEST_PATH} |
| 26 | install ${B}/test-cmdline ${D}${PTEST_PATH} |
| 27 | install ${B}/test-features ${D}${PTEST_PATH} |
| 28 | install ${B}/ethtool ${D}${PTEST_PATH}/ethtool |
| 29 | sed -i 's/^Makefile/_Makefile/' ${D}${PTEST_PATH}/Makefile |
| 30 | } |