blob: 5ca978f86ccd60a3d9192b9e0eaa0d73923a20c2 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "The GPL Ghostscript PostScript/PDF interpreter"
2DESCRIPTION = "Ghostscript is used for PostScript/PDF preview and printing. Usually as \
3a back-end to a program such as ghostview, it can display PostScript and PDF \
4documents in an X11 environment. \
5\
6Furthermore, it can render PostScript and PDF files as graphics to be printed \
7on non-PostScript printers. Supported printers include common \
8dot-matrix, inkjet and laser models. \
9"
10HOMEPAGE = "http://www.ghostscript.com"
11SECTION = "console/utils"
12
13LICENSE = "GPLv3"
14LIC_FILES_CHKSUM = "file://LICENSE;md5=70dc2bac4d0ce4448da873cd86b123fc"
15
16DEPENDS = "ghostscript-native tiff jpeg fontconfig cups libpng"
17DEPENDS_class-native = "libpng-native"
18
19UPSTREAM_CHECK_URI = "https://github.com/ArtifexSoftware/ghostpdl-downloads/releases"
20UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)\.tar"
21
Brad Bishopa5c52ff2018-11-23 10:55:50 +130022SRC_URI_BASE = "https://github.com/ArtifexSoftware/ghostpdl-downloads/releases/download/gs926/${BPN}-${PV}.tar.gz \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080023 file://ghostscript-9.15-parallel-make.patch \
24 file://ghostscript-9.16-Werror-return-type.patch \
25 file://do-not-check-local-libpng-source.patch \
26 file://avoid-host-contamination.patch \
27 file://mkdir-p.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080028"
29
30SRC_URI = "${SRC_URI_BASE} \
31 file://ghostscript-9.21-prevent_recompiling.patch \
32 file://ghostscript-9.02-genarch.patch \
33 file://objarch.h \
34 file://cups-no-gcrypt.patch \
35 "
36
37SRC_URI_class-native = "${SRC_URI_BASE} \
38 file://ghostscript-9.21-native-fix-disable-system-libtiff.patch \
39 file://base-genht.c-add-a-preprocessor-define-to-allow-fope.patch \
40 "
41
Brad Bishopa5c52ff2018-11-23 10:55:50 +130042SRC_URI[md5sum] = "806bc2dedbc7f69b003f536658e08d4a"
43SRC_URI[sha256sum] = "831fc019bd477f7cc2d481dc5395ebfa4a593a95eb2fe1eb231a97e450d7540d"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080044
45# Put something like
46#
47# PACKAGECONFIG_append_pn-ghostscript = " x11"
48#
49# in local.conf to enable building with X11. Be careful. The order
50# of the overrides matters!
51#
52#PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}"
53PACKAGECONFIG_class-native = ""
54
55PACKAGECONFIG[x11] = "--with-x --x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR}, \
56 --without-x, virtual/libx11 libxext libxt gtk+3\
57 "
58
59EXTRA_OECONF = "--with-system-libtiff --without-jbig2dec \
60 --with-fontpath=${datadir}/fonts \
61 --without-libidn --with-cups-serverbin=${exec_prefix}/lib/cups \
62 --with-cups-datadir=${datadir}/cups \
63 CUPSCONFIG="${STAGING_BINDIR_CROSS}/cups-config" \
64 "
65
66EXTRA_OECONF_append_mipsarcho32 = " --with-large_color_index=0"
67
68# Explicity disable libtiff, fontconfig,
69# freetype, cups for ghostscript-native
70EXTRA_OECONF_class-native = "--without-x --with-system-libtiff=no \
71 --without-jbig2dec \
72 --with-fontpath=${datadir}/fonts \
73 --without-libidn --disable-fontconfig \
74 --disable-freetype --disable-cups"
75
76# This has been fixed upstream but for now we need to subvert the check for time.h
77# http://bugs.ghostscript.com/show_bug.cgi?id=692443
78# http://bugs.ghostscript.com/show_bug.cgi?id=692426
79CFLAGS += "-DHAVE_SYS_TIME_H=1"
80BUILD_CFLAGS += "-DHAVE_SYS_TIME_H=1"
81
82inherit autotools
83
84do_configure_prepend () {
85 mkdir -p obj
86 mkdir -p soobj
87 if [ -e ${WORKDIR}/objarch.h ]; then
88 cp ${WORKDIR}/objarch.h obj/arch.h
89 fi
90}
91
92do_configure_append () {
93 # copy tools from the native ghostscript build
94 if [ "${PN}" != "ghostscript-native" ]; then
95 mkdir -p obj/aux soobj
96 for i in genarch genconf mkromfs echogs gendev genht packps; do
97 cp ${STAGING_BINDIR_NATIVE}/ghostscript-${PV}/$i obj/aux/$i
98 done
99 fi
100}
101
102do_install_append () {
103 mkdir -p ${D}${datadir}/ghostscript/${PV}/
104 cp -r ${S}/Resource ${D}${datadir}/ghostscript/${PV}/
105 cp -r ${S}/iccprofiles ${D}${datadir}/ghostscript/${PV}/
106}
107
108do_compile_class-native () {
109 mkdir -p obj
110 for i in genarch genconf mkromfs echogs gendev genht packps; do
111 oe_runmake obj/aux/$i
112 done
113}
114
115do_install_class-native () {
116 install -d ${D}${bindir}/ghostscript-${PV}
117 for i in genarch genconf mkromfs echogs gendev genht packps; do
118 install -m 755 obj/aux/$i ${D}${bindir}/ghostscript-${PV}/$i
119 done
120}
121
122BBCLASSEXTEND = "native"
123
124# ghostscript does not supports "arc"
125COMPATIBLE_HOST = "^(?!arc).*"