blob: d259ed53248d206ee6e48e9f07326fb73751af09 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "GNU Privacy Guard - encryption and signing tools (2.x)"
2HOMEPAGE = "http://www.gnupg.org/"
3LICENSE = "GPLv3 & LGPLv3"
4LIC_FILES_CHKSUM = "file://COPYING;md5=189af8afca6d6075ba6c9e0aa8077626 \
5 file://COPYING.LGPL3;md5=a2b6bf2cb38ee52619e60f30a1fc7257"
6
7DEPENDS = "npth libassuan libksba zlib bzip2 readline libgcrypt"
8
9inherit autotools gettext texinfo pkgconfig
10
11UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
12SRC_URI = "${GNUPG_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \
13 file://0001-Use-pkg-config-to-find-pth-instead-of-pth-config.patch \
14 file://0002-use-pkgconfig-instead-of-npth-config.patch \
15 file://0003-dirmngr-uses-libgpg-error.patch \
16 file://0004-autogen.sh-fix-find-version-for-beta-checking.patch \
17 "
18SRC_URI_append_class-native = " file://0001-configure.ac-use-a-custom-value-for-the-location-of-.patch \
19 file://relocate.patch"
20
21
Brad Bishopa5c52ff2018-11-23 10:55:50 +130022SRC_URI[md5sum] = "e23a896d634e8b81681314780f5158a4"
23SRC_URI[sha256sum] = "496c3e123ef53f35436ddccca58e82acaa901ca4e21174e77386c0cea0c49cd9"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080024
25EXTRA_OECONF = "--disable-ldap \
26 --disable-ccid-driver \
27 --with-zlib=${STAGING_LIBDIR}/.. \
28 --with-bzip2=${STAGING_LIBDIR}/.. \
29 --with-readline=${STAGING_LIBDIR}/.. \
30 --enable-gpg-is-gpg2 \
31 "
32RRECOMMENDS_${PN} = "pinentry"
33
34do_configure_prepend () {
35 # Else these could be used in prefernce to those in aclocal-copy
36 rm -f ${S}/m4/gpg-error.m4
37 rm -f ${S}/m4/libassuan.m4
38 rm -f ${S}/m4/ksba.m4
39 rm -f ${S}/m4/libgcrypt.m4
40}
41
42do_install_append() {
43 ln -sf gpg2 ${D}${bindir}/gpg
44 ln -sf gpgv2 ${D}${bindir}/gpgv
45}
46
47do_install_append_class-native() {
48 create_wrapper ${D}${bindir}/gpg2 GNUPG_BINDIR=${STAGING_BINDIR_NATIVE}
49}
50
51PACKAGECONFIG ??= "gnutls"
52PACKAGECONFIG[gnutls] = "--enable-gnutls, --disable-gnutls, gnutls"
53PACKAGECONFIG[sqlite3] = "--enable-sqlite, --disable-sqlite, sqlite3"
54
55BBCLASSEXTEND = "native"