blob: 6d2a11df347c6d473afbef37e34d2c2f15c2b34e [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "GNU Transport Layer Security Library"
2HOMEPAGE = "http://www.gnu.org/software/gnutls/"
3BUGTRACKER = "https://savannah.gnu.org/support/?group=gnutls"
4
5LICENSE = "GPLv3+ & LGPLv2.1+"
6LICENSE_${PN} = "LGPLv2.1+"
7LICENSE_${PN}-xx = "LGPLv2.1+"
8LICENSE_${PN}-bin = "GPLv3+"
9LICENSE_${PN}-openssl = "GPLv3+"
10
11LIC_FILES_CHKSUM = "file://LICENSE;md5=71391c8e0c1cfe68077e7fce3b586283 \
12 file://doc/COPYING;md5=d32239bcb673463ab874e80d47fae504 \
13 file://doc/COPYING.LESSER;md5=a6f89e2100d9b6cdffcea4f398e37343"
14
15DEPENDS = "nettle gmp virtual/libiconv libunistring"
16DEPENDS_append_libc-musl = " argp-standalone"
17
18SHRT_VER = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}"
19
20SRC_URI = "https://www.gnupg.org/ftp/gcrypt/gnutls/v${SHRT_VER}/gnutls-${PV}.tar.xz \
21 file://arm_eabi.patch \
22"
23
Brad Bishopa5c52ff2018-11-23 10:55:50 +130024SRC_URI[md5sum] = "63363d1c00601f4d11a5cadc8b5e0799"
25SRC_URI[sha256sum] = "c663a792fbc84349c27c36059181f2ca86c9442e75ee8b0ad72f5f9b35deab3a"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080026
27inherit autotools texinfo binconfig pkgconfig gettext lib_package gtk-doc
28
29PACKAGECONFIG ??= "libidn"
30
31# You must also have CONFIG_SECCOMP enabled in the kernel for
32# seccomp to work.
33PACKAGECONFIG[seccomp] = "ac_cv_libseccomp=yes,ac_cv_libseccomp=no,libseccomp"
34PACKAGECONFIG[libidn] = "--with-idn,--without-idn,libidn2"
35PACKAGECONFIG[libtasn1] = "--with-included-libtasn1=no,--with-included-libtasn1,libtasn1"
36PACKAGECONFIG[p11-kit] = "--with-p11-kit,--without-p11-kit,p11-kit"
37PACKAGECONFIG[tpm] = "--with-tpm,--without-tpm,trousers"
38
39EXTRA_OECONF = " \
40 --enable-doc \
41 --disable-libdane \
42 --disable-guile \
43 --disable-rpath \
44 --enable-local-libopts \
45 --enable-openssl-compatibility \
46 --with-libpthread-prefix=${STAGING_DIR_HOST}${prefix} \
47 --without-libunistring-prefix \
48"
49
50LDFLAGS_append_libc-musl = " -largp"
51
52do_configure_prepend() {
53 for dir in . lib; do
54 rm -f ${dir}/aclocal.m4 ${dir}/m4/libtool.m4 ${dir}/m4/lt*.m4
55 done
56}
57
58PACKAGES =+ "${PN}-openssl ${PN}-xx"
59
60FILES_${PN}-dev += "${bindir}/gnutls-cli-debug"
61FILES_${PN}-openssl = "${libdir}/libgnutls-openssl.so.*"
62FILES_${PN}-xx = "${libdir}/libgnutlsxx.so.*"
63
64BBCLASSEXTEND = "native nativesdk"