blob: fda68a293894c52e3a34c2bf1a45e9b48b16999e [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "General purpose cryptographic library based on the code from GnuPG"
2HOMEPAGE = "http://directory.fsf.org/project/libgcrypt/"
3BUGTRACKER = "https://bugs.g10code.com/gnupg/index"
4SECTION = "libs"
5
6# helper program gcryptrnd and getrandom are under GPL, rest LGPL
7LICENSE = "GPLv2+ & LGPLv2.1+ & GPLv3+"
8LICENSE_${PN} = "LGPLv2.1+"
9LICENSE_${PN}-dev = "GPLv2+ & LGPLv2.1+"
10LICENSE_dumpsexp-dev = "GPLv3+"
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
13 file://COPYING.LIB;md5=bbb461211a33b134d42ed5ee802b37ff \
14 file://LICENSES;md5=840e3bcb754e5046ffeda7619034cbd8"
15
16DEPENDS = "libgpg-error"
17
18UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
19SRC_URI = "${GNUPG_MIRROR}/libgcrypt/libgcrypt-${PV}.tar.bz2 \
20 file://0001-Add-and-use-pkg-config-for-libgcrypt-instead-of-conf.patch \
21 file://0003-tests-bench-slope.c-workaround-ICE-failure-on-mips-w.patch \
22 file://0002-libgcrypt-fix-building-error-with-O2-in-sysroot-path.patch \
23 file://0004-tests-Makefile.am-fix-undefined-reference-to-pthread.patch \
24"
Brad Bishopa5c52ff2018-11-23 10:55:50 +130025SRC_URI[md5sum] = "fbfdaebbbc6d7e5fbbf6ffdb3e139573"
26SRC_URI[sha256sum] = "f638143a0672628fde0cad745e9b14deb85dffb175709cacc1f4fe24b93f2227"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080027
28BINCONFIG = "${bindir}/libgcrypt-config"
29
30inherit autotools texinfo binconfig-disabled pkgconfig
31
32EXTRA_OECONF = "--disable-asm"
33EXTRA_OEMAKE_class-target = "LIBTOOLFLAGS='--tag=CC'"
34
35PACKAGECONFIG ??= "capabilities"
36PACKAGECONFIG[capabilities] = "--with-capabilities,--without-capabilities,libcap"
37
38do_configure_prepend () {
39 # Else this could be used in preference to the one in aclocal-copy
40 rm -f ${S}/m4/gpg-error.m4
41}
42
43# libgcrypt.pc is added locally and thus installed here
44do_install_append() {
45 install -d ${D}/${libdir}/pkgconfig
46 install -m 0644 ${B}/src/libgcrypt.pc ${D}/${libdir}/pkgconfig/
47}
48
49PACKAGES =+ "dumpsexp-dev"
50
51FILES_${PN}-dev += "${bindir}/hmac256"
52FILES_dumpsexp-dev += "${bindir}/dumpsexp"
53
54BBCLASSEXTEND = "native nativesdk"