blob: aa6e57f4da63e1eb16c1fd242b7bc4896cf1e725 [file] [log] [blame]
Ed Tanous132c0962018-05-31 15:07:49 -07001SUMMARY = "Phosphor OpenBMC KCS to DBUS"
2DESCRIPTION = "Phosphor OpenBMC KCS to DBUS."
Brad Bishopb3f2d732018-12-04 20:00:20 +00003LICENSE = "Apache-2.0"
Ed Tanous132c0962018-05-31 15:07:49 -07004LIC_FILES_CHKSUM = "file://LICENSE;md5=b1beb00e508e89da1ed2a541934f28c0"
Ed Tanous132c0962018-05-31 15:07:49 -07005DEPENDS += " \
Vernon Mauery03f22ad2019-04-12 14:06:06 -07006 sdbusplus \
William A. Kennington IIIf64e0fd2021-05-27 18:52:38 -07007 sdeventplus \
8 stdplus \
9 systemd \
Ed Tanous132c0962018-05-31 15:07:49 -070010 "
Ed Tanous9936f862022-09-19 09:13:20 -070011PROVIDES += "virtual/obmc-host-ipmi-hw"
Andrew Geissler498a9212023-12-07 15:40:32 -060012SRCREV = "e0602aaf7c721438bba08b3a5edaedaa3e427346"
Ed Tanous9936f862022-09-19 09:13:20 -070013PV = "1.0+git${SRCPV}"
14PR = "r1"
15
16SRC_URI = "git://github.com/openbmc/kcsbridge.git;branch=master;protocol=https"
17
18SYSTEMD_SERVICE:${PN} = "${PN}@${KCS_DEVICE}.service"
19S = "${WORKDIR}/git"
20
21inherit meson pkgconfig
22inherit systemd
23
24RRECOMMENDS:${PN} += "phosphor-ipmi-host"
25
26RPROVIDES:${PN} += "virtual-obmc-host-ipmi-hw"
27
28FILES:${PN} += "${systemd_system_unitdir}/${PN}@.service"
29
30KCS_DEVICE ?= "ipmi-kcs3"