blob: ff2f05735bc99582682511785ad3c88009d9f010 [file] [log] [blame]
Patrick Venturea689c3b2018-09-20 19:27:13 -07001HOMEPAGE = "http://github.com/openbmc/phosphor-ipmi-blobs"
2SUMMARY = "Phosphor OEM IPMI BLOBS Protocol Implementation"
3DESCRIPTION = "This package handles a series of OEM IPMI commands that implement the BLOB protocol for sending and receiving data over IPMI."
4PR = "r1"
5PV = "0.1+git${SRCPV}"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
8
9inherit autotools pkgconfig
10inherit obmc-phosphor-ipmiprovider-symlink
11
12DEPENDS += "autoconf-archive-native"
13DEPENDS += "phosphor-ipmi-host"
14
15S = "${WORKDIR}/git"
16SRC_URI = "git://github.com/openbmc/phosphor-ipmi-blobs"
17SRCREV = "e4accf03bbb9e3375804f397cefa81eec96a5e74"
18
19FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
20FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
21FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
22FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
23
24HOSTIPMI_PROVIDER_LIBRARY += "libblobcmds.so"