blob: 452cdeb87e3dc524d8a14a845ac85297ae944568 [file] [log] [blame]
Vishwanatha Subbanna3de84052017-04-28 15:35:10 +05301SUMMARY = "OpenPOWER Host checkstop monitor application"
2PR = "r1"
Brad Bishop2879d322018-11-07 14:45:23 -05003LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://${OPENPOWERBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
Vishwanatha Subbanna3de84052017-04-28 15:35:10 +05305
6inherit obmc-phosphor-systemd
Vishwanatha Subbanna3de84052017-04-28 15:35:10 +05307inherit allarch
8
9DEPENDS += "virtual/obmc-gpio-monitor"
10RDEPENDS_${PN} += "virtual/obmc-gpio-monitor"
11
12# For now, monitoring checkstop is the only usecase
13OBMC_HOST_MONITOR_INSTANCES = "checkstop"
14
15# Copies config file having arguments for monitoring host checkstop
16# via GPIO assertion
17SYSTEMD_ENVIRONMENT_FILE_${PN} +="obmc/gpio/checkstop"
18
Vishwanatha Subbannaa1f486e2017-07-26 16:41:03 +053019# This package is not supplying the unit file and also this is not a native
20# recipe since state-mgmt needs this package at runtime. Unsetting this below
21# variable will let the build go through
22SYSTEMD_SERVICE_${PN} ?=""
Vishwanatha Subbanna3de84052017-04-28 15:35:10 +053023
Vishwanatha Subbannaa1f486e2017-07-26 16:41:03 +053024# Install the override to set up a Conflicts relation
25SYSTEMD_OVERRIDE_${PN} +="checkstop.conf:phosphor-gpio-monitor@checkstop.service.d/checkstop.conf"
26
Andrew Geissler5c76e0c2018-03-27 13:56:26 -070027STATES = "startmin"
Vishwanatha Subbannaa1f486e2017-07-26 16:41:03 +053028GPIO_MONITOR_TMPL = "phosphor-gpio-monitor@.service"
29GPIO_MONITOR_TGTFMT = "phosphor-gpio-monitor@{1}.service"
30CHECKSTOP_MONITOR_FMT = "../${GPIO_MONITOR_TMPL}:obmc-host-{0}@{2}.target.wants/${GPIO_MONITOR_TGTFMT}"
Vishwanatha Subbannad521ee62017-06-07 21:00:16 +053031SYSTEMD_LINK_${PN} += "${@compose_list(d, 'CHECKSTOP_MONITOR_FMT', 'STATES', 'OBMC_HOST_MONITOR_INSTANCES', 'OBMC_HOST_INSTANCES')}"