blob: b38d1a8d4512c01cb36b6a0cc518eea0ead96cc9 [file] [log] [blame]
Brad Bishopa7127322015-10-06 00:27:43 -04001DESCRIPTION = "Linux kernel for OpenBMC"
2SECTION = "kernel"
3LICENSE = "GPLv2"
4
5KBRANCH ?= "dev"
6
7SRC_URI = "git://github.com/openbmc/linux;protocol=git;branch=${KBRANCH}"
8SRC_URI += "file://systemd-reqs.patch file://initrd-source.patch"
9SRC_URI += "file://obmc-bsp.scc \
10 file://obmc-bsp.cfg \
11 file://obmc-bsp-user-config.cfg \
12 file://obmc-bsp-user-patches.scc \
13 "
14
15LINUX_VERSION ?= "4.2"
16LINUX_VERSION_EXTENSION ?= "-openbmc-${SRCPV}"
17
18SRCREV="${AUTOREV}"
19
20PV = "${LINUX_VERSION}+git${SRCPV}"
21
22COMPATIBLE_MACHINE_${MACHINE} = "openbmc"
23
24inherit kernel
25require recipes-kernel/linux/linux-yocto.inc
26
27do_configure_prepend() {
28 sed -i 's/CONFIG_LOCALVERSION=.\+/CONFIG_LOCALVERSION=${LINUX_VERSION_EXTENSION}/' ${S}/arch/${ARCH}/configs/${KMACHINE}_defconfig
29}