blob: bb0aad3413d84b7d731d5d4f5ad77aa2a590da04 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Analyze Suspend"
2DESCRIPTION = "analyze-suspend is a tool for system developers to visualize \
3the activity between suspend and resume, allowing them to identify \
4inefficiencies and bottlenecks."
5HOMEPAGE = "https://01.org/suspendresume"
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
8
9# Apart from the listed RDEPENDS, analyze-suspend depends on some features
10# provided by the kernel. These options are:
11# - CONFIG_PM_DEBUG=y
12# - CONFIG_PM_SLEEP_DEBUG=y
13# - CONFIG_FTRACE=y
14# - CONFIG_FUNCTION_TRACER=y
15# - CONFIG_FUNCTION_GRAPH_TRACER=y
16
17RDEPENDS_${PN} += "python-core python-datetime python-stringold"
18
19SRC_URI = "git://github.com/01org/suspendresume.git;protocol=https"
Brad Bishopa891d152019-09-13 06:17:45 -040020SRCREV = "cf59527dc24fdd2f314ae4dcaeb3d68a117988f6"
Brad Bishopc342db32019-05-15 21:57:59 -040021
22S = "${WORKDIR}/git"
23
24do_install() {
25 install -Dm 0755 analyze_suspend.py ${D}${bindir}/analyze_suspend.py
26 install -Dm 0644 README ${D}${docdir}/analyze-suspend/README
27}
28
29BBCLASSEXTEND = "native"