Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Hardware RNG based on CPU timing jitter" |
| 2 | DESCRIPTION = "The Jitter RNG provides a noise source using the CPU execution timing jitter. \ |
| 3 | It does not depend on any system resource other than a high-resolution time \ |
| 4 | stamp. It is a small-scale, yet fast entropy source that is viable in almost \ |
| 5 | all environments and on a lot of CPU architectures." |
| 6 | HOMEPAGE = "http://www.chronox.de/jent.html" |
| 7 | LICENSE = "GPLv2+ | BSD" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=e52365752b36cfcd7f9601d80de7d8c6 \ |
| 9 | file://COPYING.gplv2;md5=eb723b61539feef013de476e68b5c50a \ |
| 10 | file://COPYING.bsd;md5=66a5cedaf62c4b2637025f049f9b826f \ |
| 11 | " |
| 12 | SRC_URI = "git://github.com/smuellerDD/jitterentropy-library.git \ |
| 13 | file://0001-fix-do_install-failure-on-oe.patch \ |
| 14 | " |
| 15 | SRCREV = "f5a80c6f3fcc6deebd0eabf75324f48aed1afbce" |
| 16 | S = "${WORKDIR}/git" |
| 17 | |
| 18 | do_configure[noexec] = "1" |
| 19 | |
| 20 | LDFLAGS += "-Wl,-O0" |
| 21 | |
| 22 | do_install () { |
| 23 | oe_runmake install INCDIR="/include" \ |
| 24 | DESTDIR="${D}" \ |
| 25 | PREFIX="${exec_prefix}" \ |
| 26 | LIBDIR="${baselib}" |
| 27 | } |
| 28 | |