blob: 272106a6ae91a35feaa3a03845a7fedf022f5d64 [file] [log] [blame]
Grant Williamsa8c0af02022-04-29 12:03:41 -05001SUMMARY = "Phosphor OpenBMC mori Firmware Upgrade Command"
2DESCRIPTION = "Phosphor OpenBMC mori Firmware Upgrade Comman Daemon"
3
4PR = "r1"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
7
8inherit systemd
9inherit obmc-phosphor-systemd
10
11DEPENDS += "systemd"
12DEPENDS += "phosphor-ipmi-flash"
13RDEPENDS:${PN} += "libsystemd"
14RDEPENDS:${PN} += "bash"
15
16SRC_URI = " \
17 file://mori-fw.sh \
18 file://mori-fw-ver.service \
19 file://mori-fw-ver.sh \
20 file://mori-lib.sh \
21 "
22
23SYSTEMD_PACKAGES = "${PN}"
24SYSTEMD_SERVICE:${PN} = " \
25 mori-fw-ver.service \
26 "
27
28do_install () {
29 install -d ${D}${sbindir}
30 install -d ${D}${libexecdir}/${PN}
31 install -m 0755 ${WORKDIR}/mori-fw.sh ${D}${sbindir}/mori-fw.sh
32 install -m 0755 ${WORKDIR}/mori-fw-ver.sh ${D}${libexecdir}/${PN}/mori-fw-ver.sh
33 install -m 0755 ${WORKDIR}/mori-lib.sh ${D}${libexecdir}/${PN}/mori-lib.sh
34 install -d ${D}${systemd_system_unitdir}
35 install -m 0644 ${WORKDIR}/mori-fw-ver.service ${D}${systemd_system_unitdir}
36}