blob: 5f638ae0f13d6a1cbd22ac15746c9341b011f380 [file] [log] [blame]
Deepak Kodihalli14c47d22017-03-17 03:51:13 -05001SUMMARY = "Open POWER DBus Interfaces"
2DESCRIPTION = "Generated bindings, using sdbus++, for the openpower YAML"
3PR = "r1"
Patrick Venture92feebc2018-10-02 19:51:03 -07004PV = "1.0+git${SRCPV}"
Patrick Venturef9afb7a2018-11-03 09:10:39 -07005LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
Deepak Kodihalli14c47d22017-03-17 03:51:13 -05007
8S = "${WORKDIR}/git"
9
10inherit autotools pkgconfig
Deepak Kodihalli14c47d22017-03-17 03:51:13 -050011inherit pythonnative
Marri Devender Rao8dd77982017-05-29 01:33:26 -050012inherit phosphor-dbus-yaml
Deepak Kodihalli14c47d22017-03-17 03:51:13 -050013
14DEPENDS += "autoconf-archive-native"
15DEPENDS += "sdbus++-native"
Matt Spinler47c4ef42019-07-25 11:00:49 -050016DEPENDS += "phosphor-dbus-interfaces"
Deepak Kodihalli14c47d22017-03-17 03:51:13 -050017
Deepak Kodihalli14c47d22017-03-17 03:51:13 -050018SRC_URI += "git://github.com/openbmc/openpower-dbus-interfaces"
Andrew Geissleraa753482019-08-14 12:20:38 +000019SRCREV = "bd2f0cb4123e024fd1cbd9d867bdbe9a7639335e"
Deepak Kodihalli14c47d22017-03-17 03:51:13 -050020
21DEPENDS_remove_class-native = "sdbus++-native"
22DEPENDS_remove_class-nativesdk = "sdbus++-native"
23
24PACKAGECONFIG ??= "libopenpower_dbus"
25PACKAGECONFIG[libopenpower_dbus] = " \
26 --enable-libopenpower_dbus, \
27 --disable-libopenpower_dbus, \
28 systemd sdbusplus, \
29 libsystemd sdbusplus \
30 "
31
32PACKAGECONFIG_remove_class-native = "libopenpower_dbus"
33PACKAGECONFIG_remove_class-nativesdk = "libopenpower_dbus"
34
35BBCLASSEXTEND += "native nativesdk"