Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | SUMMARY = "Download, build, install, upgrade, and uninstall Python packages" |
| 2 | HOMEPAGE = "https://pypi.org/project/setuptools" |
| 3 | SECTION = "devel/python" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;beginline=1;endline=19;md5=7a7126e068206290f3fe9f8d6c713ea6" |
| 6 | |
| 7 | inherit pypi python_setuptools_build_meta |
| 8 | |
| 9 | SRC_URI:append:class-native = " file://0001-conditionally-do-not-fetch-code-by-easy_install.patch" |
| 10 | |
| 11 | SRC_URI += "file://0001-change-shebang-to-python3.patch \ |
| 12 | file://0001-_distutils-sysconfig.py-make-it-possible-to-substite.patch" |
| 13 | |
| 14 | SRC_URI[sha256sum] = "101bf15ca723beef42c8db91a761f3748d4d697e17fae904db60c0b619d8d094" |
| 15 | |
| 16 | DEPENDS += "${PYTHON_PN}" |
| 17 | |
| 18 | RDEPENDS:${PN} = "\ |
| 19 | ${PYTHON_PN}-2to3 \ |
| 20 | ${PYTHON_PN}-compile \ |
| 21 | ${PYTHON_PN}-compression \ |
| 22 | ${PYTHON_PN}-ctypes \ |
| 23 | ${PYTHON_PN}-email \ |
| 24 | ${PYTHON_PN}-html \ |
| 25 | ${PYTHON_PN}-json \ |
| 26 | ${PYTHON_PN}-netserver \ |
| 27 | ${PYTHON_PN}-numbers \ |
| 28 | ${PYTHON_PN}-pickle \ |
| 29 | ${PYTHON_PN}-pkg-resources \ |
| 30 | ${PYTHON_PN}-pkgutil \ |
| 31 | ${PYTHON_PN}-plistlib \ |
| 32 | ${PYTHON_PN}-shell \ |
| 33 | ${PYTHON_PN}-stringold \ |
| 34 | ${PYTHON_PN}-threading \ |
| 35 | ${PYTHON_PN}-unittest \ |
| 36 | ${PYTHON_PN}-xml \ |
| 37 | " |
| 38 | |
| 39 | BBCLASSEXTEND = "native nativesdk" |
| 40 | |
| 41 | # The pkg-resources module can be used by itself, without the package downloader |
| 42 | # and easy_install. Ship it in a separate package so that it can be used by |
| 43 | # minimal distributions. |
| 44 | PACKAGES =+ "${PYTHON_PN}-pkg-resources " |
| 45 | FILES:${PYTHON_PN}-pkg-resources = "${PYTHON_SITEPACKAGES_DIR}/pkg_resources/*" |
| 46 | RDEPENDS:${PYTHON_PN}-pkg-resources = "\ |
| 47 | ${PYTHON_PN}-compression \ |
| 48 | ${PYTHON_PN}-email \ |
| 49 | ${PYTHON_PN}-plistlib \ |
| 50 | ${PYTHON_PN}-pprint \ |
| 51 | " |
| 52 | |
| 53 | # This used to use the bootstrap install which didn't compile. Until we bump the |
| 54 | # tmpdir version we can't compile the native otherwise the sysroot unpack fails |
| 55 | INSTALL_WHEEL_COMPILE_BYTECODE:class-native = "--no-compile-bytecode" |