blob: 530085bbb89b03c78a13e793f3e1f6769c042f4c [file] [log] [blame]
Sergey Solominaac4adf2016-11-28 15:03:24 -06001SUMMARY = "POWER9 VCS workaround"
2DESCRIPTION = "Apply fixes over FSI to POWER9 CPUs prior to host power on"
3PR = "r1"
4
5inherit obmc-phosphor-systemd
6inherit obmc-phosphor-license
7
8FILESEXTRAPATHS_prepend := "${THISDIR}/op-pdbg-host-control:"
9
10RDEPENDS_${PN} += "pdbg \
11 virtual-p9-vcs-workaround"
12
13S = "${WORKDIR}"
14SRC_URI += "file://vcs_workaround.sh"
15
16do_install() {
17 install -d ${D}${bindir}
18 install -m 0755 ${WORKDIR}/vcs_workaround.sh \
19 ${D}${bindir}/vcs_workaround.sh
20}
21
22TMPL = "vcs_workaround@.service"
23INSTFMT = "vcs_workaround@{0}.service"
24TGTFMT = "obmc-chassis-start@{0}.target"
25FMT = "../${TMPL}:${TGTFMT}.wants/${INSTFMT}"
26
27SYSTEMD_SERVICE_${PN} += "${TMPL}"
28SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"
29SYSTEMD_SUBSTITUTIONS += "MACHINE:${MACHINE}:${TMPL}"