Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | # Copyright (C) 2013 Khem Raj <raj.khem@gmail.com> |
| 2 | # Released under the MIT license (see COPYING.MIT for the terms) |
| 3 | |
| 4 | SUMMARY = "Library of utility functions from BSD systems" |
| 5 | DESCRIPTION = "This library provides useful functions commonly found on BSD systems, \ |
| 6 | and lacking on others like GNU systems, thus making it easier to port \ |
| 7 | projects with strong BSD origins, without needing to embed the same \ |
| 8 | code over and over again on each project." |
| 9 | |
| 10 | HOMEPAGE = "http://libbsd.freedesktop.org/wiki/" |
| 11 | # There seems to be more licenses used in the code, I don't think we want to list them all here, complete list: |
| 12 | # OE @ ~/projects/libbsd $ grep ^License: COPYING | sort |
| 13 | # License: BSD-2-clause |
| 14 | # License: BSD-2-clause |
| 15 | # License: BSD-2-clause-NetBSD |
| 16 | # License: BSD-2-clause-author |
| 17 | # License: BSD-2-clause-verbatim |
| 18 | # License: BSD-3-clause |
| 19 | # License: BSD-3-clause |
| 20 | # License: BSD-3-clause |
| 21 | # License: BSD-3-clause-Peter-Wemm |
| 22 | # License: BSD-3-clause-Regents |
| 23 | # License: BSD-4-clause-Christopher-G-Demetriou |
| 24 | # License: BSD-4-clause-Niels-Provos |
| 25 | # License: BSD-5-clause-Peter-Wemm |
| 26 | # License: Beerware |
| 27 | # License: Expat |
| 28 | # License: ISC |
| 29 | # License: ISC-Original |
| 30 | # License: public-domain |
| 31 | # License: public-domain-Colin-Plumb |
| 32 | LICENSE = "BSD-4-Clause & ISC & PD" |
| 33 | LIC_FILES_CHKSUM = "file://COPYING;md5=08fc4e66be4526715dab09c5fba5e9e8" |
| 34 | SECTION = "libs" |
| 35 | |
| 36 | SRC_URI = " \ |
| 37 | http://libbsd.freedesktop.org/releases/${BPN}-${PV}.tar.xz \ |
| 38 | file://0001-src-libbsd-overlay.pc.in-Set-Cflags-to-use-I-instead.patch \ |
| 39 | " |
| 40 | SRC_URI_append_libc-musl = " \ |
| 41 | file://0001-Replace-__BEGIN_DECLS-and-__END_DECLS.patch \ |
| 42 | file://0002-Remove-funopen.patch \ |
| 43 | " |
| 44 | |
| 45 | SRC_URI[md5sum] = "d9e6980fbfe44f94fd92b89a33cce67d" |
| 46 | SRC_URI[sha256sum] = "f548f10e5af5a08b1e22889ce84315b1ebe41505b015c9596bad03fd13a12b31" |
| 47 | |
| 48 | inherit autotools pkgconfig |
| 49 | |
| 50 | BBCLASSEXTEND = "native nativesdk" |